Основные сведения о программе

Программа визуализации генеалогических деревьев "Родственники" предназначена для составления и показа генеалогических деревьев и хранения генеалогической информации в файлах.

Особенности программы:

  1. Основная идея, которую автор стремился реализовать в программе "Родственники" - сделать представление генеалогического дерева наглядным, навигацию по нему - удобной, а процесс его составления - простым.
  2. Программа полностью поддерживает стандарт хранения генеалогической информации GEDCOM версии 5.5. Это полнофункциональный инструмент для профессиональных генеалогов; в то же время автор стремился сделать ее пригодной и для использования любителями и новичками в генеалогии.
    Структура данных программы
  3. Программа показывает семейные связи между родственниками в виде ниспадающего дерева. Каждый родственник представляется в виде прямоугольной рамки с тремя строками текста: 1-я строка - имя и отчество, 2-ая - фамилия и 3-я - даты жизни. Рамки мужчин, женщин и родственников неизвестного пола имеют разный цвет. Связи муж-жена показываются линиями под рамками, связи между сестрами и братьями - линиями над рамками, а связи родители-дети - вертикальными линиями.
  4. Масштаб изображения дерева можно менять в любых пределах - и охватить все дерево одним взглядом или подробно рассмотреть любую его часть вблизи. Для изменения масштаба можно использовать как колёсико мыши, так и меню. Также, когда масштаб мелкий, специальное окно "Лупа" поможет увидеть нужные участки дерева в масштабе 1:1.
    Масштабирование
    Лупа
  5. Рамки родственников можно перетаскивать мышью и передвигать клавишами по одной и группами, выделять, выравнивать по горизонтали и вертикали, равномерно распределять, менять местами, удалять, копировать и вырезать из одного места, вставлять в другое. Двойной щелчок на рамке покажет вам полную информацию о данном родственнике.
    Как выделять родственников и семьи
    Меню "Вид" - "Выровнять..."
    Меню "Вид" - "Распределить..."
    Меню "Вид" - "Поменять местами"
    Меню "Правка": Копировать, Вырезать, Удалить; Выпадающее меню Вставить.
    Информационное окно
  6. Родственники и семьи могут иметь ссылки на другие файлы (так называемые медиа-файлы) - документы, фотографии, рисунки, страницы в Интернете, файлы других деревьев и т.п. Список ссылок показывается в Информационном окне данного родственника или семьи, где каждую ссылку можно открыть и посмотреть указанный в ней документ.
    При составлении дерева пользователь может создать множество ссылок на различные файлы, хранящиеся в разных директориях компьютера, и подчас бывает трудно запомнить, где что находится. Кроме того, файлы, на которые указывают ссылки, могут быть случайно переименованы, удалены или перемещены в другое место, но ссылки по-прежнему будут указывать на уже несуществующие файлы. В этом случае, когда нужно будет перенести дерево и все относящиеся к нему файлы на другой компьютер, часть файлов могут просто потеряться. Специальный инструмент программы, Медиа Мастер, позволяет получить список всех ссылок дерева, увидеть, какие из них действительны, а какие нет, куда они реально указывают и сколько всего их файлы занимают места на диске. Тут же можно исправить такие потерянные ссылки или удалить их, а затем подготовить дерево к переносу, записав его со всеми его медиа-файлами в отдельную директорию или ZIP-архив.
    Создание и редактирование ссылок
    Медиа Мастер
  7. Программа может импортировать информацию из файлов формата GEDCOM 5.5 (*.ged). Файлы можно сохранять как в собственном формате (*.rel), так и экспортировать в GEDCOM 5.5. При этом в файлах сохраняется полная графическая информация о расположении элементов дерева.
    Меню "Файл" - "Открыть/Сохранить"
    Импорт из GEDCOM 5.5 файла
    Экспорт в GEDCOM 5.5 файл
  8. Также предусмотрен экспорт в текстовый формат HTML и графический формат GIF, встроенный в интерактивную HTML-страницу, а также в интерактивный Adobe Flash, что делает возможным размещение генеалогических деревьев в Интернете.
    Экспорт в HTML
    Экспорт в графику в HTML
    Экспорт в Интерактивный Adobe Flash™
  9. Изображение дерева можно распечатать в любом масштабе - и на широкоформатном плоттере и на обычном домашнем принтере формата А4 - и при этом или уместить все на одном листе, или расположить на любом их количестве.
    Диалоговое окно "Печать"
  10. Списки всех родственников и семей дерева показываются в отдельных окнах программы. Вы можете получить информацию о каждом элементе такого списка, вызвать его на редактирование или удалить, найти его положение в дереве. Поддерживается также список т.н. "записей общего пользования".
    Меню "Вид" - "Список родственников"
    Меню "Вид" - "Список семей"
    Меню "Вид" - "Общие записи"
    Меню "Вид" - "Заголовок файла"
  11. Родословную отдельного родственника, т.е. линии его прямых предков и потомков, можно рассмотреть в специальном окне. Для родословной можно установить любое количество показываемых поколений, расположить её в горизонтальном или вертикальном направлении, а также сохранить в файле.
    Окно "Родословная"
    Выпадающее меню
  12. Редактирование каждого из элементов дерева - заголовка файла, родственников, семей и записей общего пользования осуществляются в специальном Редакторе. Он вызывается для заголовка из главного меню, для родственников, семей и записей - из соответствующего списка, а для родственников также из выпадающего меню при щелчке правой кнопкой мыши на рамке родственника.
    Редактирование заголовка файла
    Редактирование родственника
    Редактирование семьи
    Редактирование записи общего пользования
  13. Найти необходимого родственника, семью или запись общего пользования можно с помощью встроенного механизма поиска. В списках родственников и семей есть свой "быстрый поиск" по фамилии-имени, "Поиск" в меню "Правка" позволяет искать по основным элементам - имени, фамилии, датам рождения и смерти, комментариям, ссылкам, а также "везде" - то есть по всем элементам записей.
    Быстрый поиск родственников по всем элементам можно сделать также прямо из главного окна программы, не вызывая диалогового окна поиска. Для этого введите искомое слово (или несколько слов через пробел) в поле "Быстрый поиск..." в верхнем правом углу окна программы и нажмите Ввод. Если задано несколько слов, то поиск будет производиться по ВСЕМ словам.
    Меню "Правка" - "Поиск"
    Быстрый поиск...
  14. В программе реализована расширенная поддержка пользовательских тэгов, известных также как "тэги, определенные пользователем". Вы можете создавать свои собственные тэги, редактировать их, тонко настраивать их тип данных в специальном редакторе пользовательских тэгов. Информация о пользовательских тэгах полностью сохраняется в файлах, в том числе при экспорте в GEDCOM формат.
    Меню "Правка" - "Пользовательские тэги"

О полной поддержке GEDCOM 5.5:
Поддерживаются все тэги стандарта GEDCOM 5.5, кроме одного - встроенного типа медиафайлов (тэг OBJE). При этом другая разновидность этого тэга - "OBJE-ссылка на внешние файлы" - поддерживается полностью и даже в несколько расширенном значении. Почему автор отказался от реализации "OBJE-встроенного"? Очевидно, что идея хранения медиафайлов внутри GEDCOM файлов была ошибочна с самого начала, и очень немногие из известных автору генеалогических программ поддерживают этот тэг. Ссылки на внешние файлы (подобно тому, как это реализовано в HTML) гораздо удобнее, проще и эффективнее.

О поддержке формата GEDCOM 6.0 (известного также как GEDCOM XML):
С момента публикации предложений по формату GEDCOM 6.0 (т.н. draft-версии) в 2002 году прошло уже немало времени, однако никаких генеалогических программ, поддерживающих этот формат, так и не было выпущено (по крайней мере, автор не знает ни одной). Даже автор самого GEDCOMа, Церковь Иисуса Христа Святых последних дней, до сих пор не выпустила своей программы, способной работать с этим форматом. Более того, авторы практически оставили разработчиков генеалогического программ без какой-либо поддержки и уже давно не отвечают ни на какие запросы по поводу своего формата.
Сам формат 6.0, хотя и предлагает более современный способ хранения информации (XML), грешит еще большими недостатками, чем его предшественник, GEDCOM 5.5.
Автор данной программы в настоящее время не планирует поддержку формата 6.0, хотя, если данный формат получит распространение, в дальнейшем может поддержать его.

Об особенностях импорта GEDCOM файлов:
Как известно, файлы GEDCOM не содержат никакой графической информации, т.е. такой, которая позволила так расположить элементы дерева, чтобы они выглядели красиво, логично и удобно для навигации. Поэтому в данной программе предусмотрена автоматическая расстановка при импорте. Надо сказать, что полное решение этой задачи для любых генеалогических деревьев с их громадным разнообразием родственных связей является практически неразрешимой - это признают даже ученые-математики и специалисты в теории графов. Алгоритму данной программы (еще, конечно, весьма несовершенному) удается в большинстве случаев правильно расположить родственников по поколениям и семьям, однако почти любой файл после импорта требует "ручной доводки" - расположения родственников по местам мышкой. Для небольших файлов (менее тысячи человек) это не представляет особого труда, но для больших, да если еще родственные связи в дереве не вполне обычны (браки между родственниками, между поколениями - например, брак дяди и племянницы, или в файле просто имеются ошибки) то расстановка такого дерева может оказаться нетривиальной задачей и занять много часов. Утешением в этом может служить то, что такая расстановка сама по себе является весьма увлекательным занятием (как пасьянс!), к тому же это ведь ВАШИ родные и близкие...
В программе имеются насколько функций, облегчающих такую работу - это одиночное и групповое перетаскивание мышкой, команда "поменять местами", различные типы выравнивания. При экспорте в GEDCOM файл информация о расположении элементов дерева полностью сохраняется в файле, поэтому ручную расстановку надо выполнить только один раз, при самом первом импорте.

О "расширенной" поддержке пользовательских тэгов:
Попытка определения пользовательских тегов (иначе говоря, новых типов данных) была осуществлена в GEDCOM версии 5.3 (тэг SCHEMA), однако уже в версии 5.5 её авторы отказались от этой идеи по причине, как они объяснили, "сложности и преждевременности для реализации в современных программах". В программе "Родственники" пользовательские тэги поддерживаются, причем если такие тэги описаны в GEDCOM файле в SCHEMA, то информация о них при импорте такого файла полностью сохраняется и может быть отредактирована в специальном редакторе Пользовательских тэгов. Сам тэг SCHEMA при этом остается невидимым для пользователя. "Расширенная" поддержка означает, что пользовательским тэгам придаются дополнительные атрибуты, более полно описывающие такие тэги как отдельные типы данных и улучшающие их применение.


Структура данных программы

Структура данных программы "Родственники".

Формат хранения генеалогической информации GEDCOM был предложен Церковью Иисуса Христа Святых последних дней ("Церковь мормонов") в 80-х годах и стал de facto общепризнанным стандартом. Именно по причине глобального распространения GEDCOMа структура данных в программе "Родственники" аналогична структуре данных этого формата.

Данные в программе представлены набором записей. В таблице ниже показаны типы записей и их соответствие GEDCOM-тэгам:
Тип записи | GEDCOM-тэг | Примечание
Заголовок | HEAD | Заголовок файла содержит информацию, общую для всего файла. Например, программа-создатель данного файла, автор, кодировка файла, дата его создания и т.п. У файла может быть только один заголовок.
Родственник | INDI | Индивидуум, персона. (Автор предпочел использовать слово "родственник", хотя не все люди в одном файле обязательно являются родственниками по отношению друг к другу, т.к. файл может содержать более чем одно генеалогическое дерево). Родственники имеют ссылки на семьи, в которых они являются супругами и детьми, таким образом, каждый родственник "знает", к каким семьям он принадлежит. В файле должна быть, по крайней мере, одна запись этого типа.
Семья | FAM | В семье может быть не более одного мужа и одной жены. Если кто-то имеет более одного супруга, то это будет отдельная семья. Семьи имеют ссылки на родственников, которые являются супругами и детьми в данной семье, таким образом, любая семья "знает" своих членов. Каждая семья должна иметь, по крайней мере, двух членов.
Комментарий | NOTE | Комментарий, заметки. Другие записи могут использовать такой комментарий как общий для всех. Такого рода записи называются "записями общего пользования".
Источник | SOUR | Источник информации в виде записи общего пользования. На такую запись могут ссылаться несколько других записей, если они имеют общий источник информации.
Репозиторий | REPO | Архив, хранилище данных, библиотека, музей, база данных и т.п., т.е. всё, что может хранить документы. На такую запись, например, могут ссылаться несколько источников, если они хранятся в одном и том же месте.
Автор | SUBM | Автор данных, лицо или организация, предоставившая информацию. Если данные для нескольких записей были предоставлены одним автором, то они могут сообща ссылаться на такую запись общего пользования. Автором данных для всех записей файла по умолчанию считается тот автор, который указан в заголовке файла, если в записи не указано иначе. Таким образом, в файле должен быть, по крайней мере, один автор для всего файла, плюс авторы данных других записей, если таковые существуют.
Подпись | SUBN | Эта запись (может быть только одна в файле) содержит инструкции и информацию, необходимые для получающей данный файл системы. Используется только в собственной системе хранения генеалогической информации Церкви мормонов.

Записи типа "встроенный медиа-объект" (GEDCOM-тэг OBJE) не поддерживаются. См. О полной поддержке GEDCOM 5.5.

Достаточно подготовленный пользователь может использовать Редактор пользовательских тэгов и создать свои собственные типы записей.

Записи содержат элементы, которые, в свою очередь, могут содержать другие элементы, и т.д. Таким образом, каждая запись представляет собою "дерево элементов", подобное структуре директорий и файлов. Каждый элемент имеет свой тэг, соответствующий GEDCOM-тэгу и значение. Типы значений элементов перечислены в следующей таблице:

Тип значения | Описание
Пусто | Элемент не имеет значения. Такой элемент просто содержит другие элементы.
Строка | Значение элемента - одна строка текста.
Текст | Значение элемента - многострочный текст неограниченной длины.
Ссылка | Значение элемента - ссылка на другую запись. Например, в записи Родственник элемент "Ребенок в семье" (тэг FAMC) - это ссылка на запись Семья, в которой данный родственник является сыном или дочерью.

В формате GEDCOM одинаковые тэги могут иметь разный смысл в зависимости от контекста, т.е. от того, где в дереве элементов они расположены. Например, тэг TITL применительно к Родственнику означает "титул, звание", а в Источнике это "название, заглавие документа". В программе "Родственники" каждая запись и каждый её элемент снабжены своим шаблоном, который указывает тип, который имеет данный элемент, а также описание данного элемента, текст помощи для его создания/редактирования, минимальное и максимальное количество элементов данного типа в родительском элементе и т.п. Таким образом элементы с одинаковыми тэгами различаются в зависимости от своего положения в дереве элементов. Шаблон также хранит список всех возможных значений для тех элементов, которые могут иметь только одно значение из заранее заданного списка.

Примечание: Комментарии (тэг NOTE) и Источники (тэг SOUR) могут быть как элементами в записях, так и отдельными записями общего пользования. Благодаря тому, что они имеют разные шаблоны, программа различает их, помогая пользователю не спутать их. Например, в дереве элементов вы можете увидеть как элемент с названием "Комментарий", так и элемент с названием "Ссылка на комментарий" - это разные типы:
Комментарий - это простой текстовый комментарий, он принадлежит только данному родительскому элементу (или записи);
Ссылка на комментарий - это ссылка на запись общего пользования типа Комментарий.

Полное дерево возможных элементов для каждого типа записи можно увидеть в Справочнике по структуре записей.

GEDCOM - сложный и полноценный формат, позволяющий хранить практически любую генеалогическую информацию, однако в большинстве случаев рядовому пользователю для целей "домашней родословной" не нужно всего того разнообразия данных, которые предлагает этот формат. Поэтому автор программы решил выделить некоторую информацию о родственниках и семьях, как основную, главную, и сделать доступ к ней упрощенным, а всю остальную информацию убрать на второй план, чтобы она не мешала восприятию главной. Какая же информация является основной - той, которую желательно донести до "читателя" вашего фамильного дерева в первую очередь? По мнению автора, для любого объекта (родственник, семья и т.п.) это две категории данных: а) комментарии и б) ссылки.

Комментарий - это текст произвольной длины, назначение которого очевидно - описание объекта, сообщение о нем самой разнообразной информации. Комментарий может вместить в себя любую информацию об объекте и вообще говоря, можно было бы обойтись только этим типом данных, но в реальности приходится мириться с тем, что для целей компьютерной обработки информация должна быть структурирована.

Ссылка - адрес документа, относящегося к данному объекту. Это может быть цифровая фотография, текстовый файл, документ Word, веб-страничка в Интернете, музыкальный или видео файл, другое генеалогическое дерево и т.д. - все, что можно хранить в электронном виде.

Другая первостепенная информация:

Для родственника - это имя-фамилия и даты жизни, ближайшие родственники: мать, отец, супруг/супруга, дети.

Для семьи - муж, жена, дети, дата и место бракосочетания.

Пример такого подхода: информационное окно, показывающее сведения о родственнике:

1) В положении переключателя Вид "Комментарии+Ссылки" окно показывает основные данные: имя, даты жизни, сведения о ближайших родственниках, комментарий, ссылки.
Если комментариев у данного родственника несколько, то будут показаны все они, разделенные друг от друга горизонтальной чертой.

2) Если переключить Вид в положение "Дерево", то можно увидеть любую информацию, которая есть о данном родственнике - в данном случае пользователь выбрал информацию о месте погребения.

Аналогичным образом работает Редактор записей - кнопки в нижней части диалогового окна редактора позволяют быстро вызвать на редактирование основные элементы записи, а при необходимости редактирования других элементов используется дерево элементов.

Пример окна Редактора при редактировании родственника:
Кнопки "Имя...", "Пол...", "Рожд. и смерть..." и др. вызывают соответствующие диалоговые окна для редактирования этих элементов.

О максимальной длине строкового значения:
В стандарте GEDCOM для каждой строки файла установлена предельная длина - 256 символов, из которых на значение (за вычетом номера уровня и тэга) остается максимум 248 символов. Это предел был установлен еще во времена маломощных компьютеров, и позднее это архаичное ограничение так и осталось. Программа "Родственники" не ограничивает длину одиночной строки, хотя при экспорте в GEDCOM файл, если элемент имеет тип многострочный текст, разбивает его на сроки (тэги CONT и CONC) согласно формату GEDCOM.


Многоязычный интерфейс

Программа "Родственники" поддерживает многоязычный интерфейс. Ресурсы для каждого языка находятся в директории lang в поддиректориях с двухбуквенными именами, совпадающими с кодом языка согласно стандарта ISO-639-1 (См. ISO Language Codes)

В настоящей версии поддерживаются 2 языка: английский (основной) и русский. Соответственно, в директории программы находятся 2 поддиректории: en и ru.

    При запуске программа устанавливает свой язык следующим образом:
  1. Прочитывает файл конфигурации Relatives.ini и, если там есть строка "lang=xx", устанавливает язык xx, если директория xx присутствует в директории lang.
    Если язык не установлен таким образом, то:
  2. Определяет язык операционной системы Windows и устанавливает этот язык, если соответствующая директория присутствует в директории lang.
    Если язык не установлен таким образом, то:
  3. Устанавливает английский язык.

См. также:
Диалоговое окно "Конфигурация"
Меню "Сервис"


Информационное окно

В информационном окне показываются сведения о записи - родственнике, семье, заголовке файла или записи общего пользования.

Вызвать информационное окно можно следующими способами:

    Для родственника:
  • Дважды щелкнув по рамке родственника.
  • Щелкнув на рамке родственника правой кнопкой мыши и выбрав в выпадающем меню пункт "Сведения".
  • Выделив родственника в Списке родственников и нажав кнопку "Сведения".
    Для семьи:
  • Выделив семью в Списке семей и нажав кнопку "Сведения".
    Для заголовка файла:
  • Выбрав пункт "Заголовок файла" в меню "Вид".
    Для записи общего пользования:
  • Выделив запись в Списке записей общего пользования и нажав кнопку "Сведения".

В заголовке информационного окна показывается краткое описание записи и в квадратных скобках - ее идентификационный номер (ID).

В верхней части окна - более развернутое описание (зависит от вида записи).

В средней части окна - сведения о записи в формате, зависящим от выбранной закладки.

  1. Закладка "Комментарии+Ссылки": показываются только два вида сведений о записи - Комментарии (тег NOTE) и Ссылки (тэг OBJE).
    Если комментариев несколько, они показываются друг за другом, разделенные горизонтальной чертой. Если комментарий - это ссылка за запись общего пользования, то показывается её содержимое-текст.
    Ссылки на документы показываются в выпадающем списке. Причем это все ссылки, имеющиеся в данной записи, т.е. включая и те, которые принадлежат элементам записи, например, Родственник-Рождение. Если нажать на кнопку "Показать", то выбранный документ будет открыт. Какая программа его откроет, зависит от того, с какой программой ассоциировано расширение файла документа - ".doc" откроется в Microsoft Word, ".jpg", ".gif", ".bmp" или ".png" - в собственном просмотрщике рисунков, ".html" или интернет-ссылка - в браузере, и т.д.
    Вид "Комментарии+Ссылки" - это "базисный" вид, показывающий только основные элементы записи - то, что пользователю в основном будет интересно.
  2. Закладка Дерево: слева показывается структура записи в виде дерева элементов (наподобие дерева директорий и файлов), сверху - описание выбранного элемента, а справа - его значение.
    Если элемент выделяется красным цветом, то это означает, что он - ссылка на другую запись - дважды щелкнув по нему, можно открыть эту запись в Информационном окне. Кнопкой "Назад" можно затем вернуться к предыдущей записи - так можно "пройтись" по всем записям, связанными ссылками.
  3. Закладка "Фото" показывает (в виде эскизов) ссылки, но только те, которые являются фотографиями и рисунками. Двойной щелчок на таком эскизе откроет изображение в соответствующей программе. Если файлы изображений находятся в Интернете, то для создания эскизов они скачиваются с сети (в это время эскиз показывает "Загрузка...") и сохраняются во временном файле, поэтому открытие такого изображения не приведет к повторной загрузке файла, а будет использована сохраненная копия. В левом верхнем углу можно установить размер иконок от 50 до 250 пикселей.

Список "Шрифт" позволяет установить размер шрифта в окне комментариев - полезная функция, когда Ваше дерево будут рассматривать пожилые люди.

Переключатель "Всегда сверху": если он включен, то Информационное окно будет всегда оставаться поверх других окон.

См. также: Структура данных программы "Родственники"


Выпадающее меню

Выпадающее меню появляется при щелчке правой кнопкой мыши в области дерева:

1) Пункт "Новый родственник" доступен только тогда, когда щелчок произошел на свободном от рамок родственников месте. Родственник, созданный посредством этого пункта, будет помещен в место щелчка серединкой верхней границы своей рамки. Остальные пункты будут доступны только тогда, когда щелчок произошел на рамке какого-либо родственника.

2) Пункт "Правка" вызывает данного родственника на редактирование в Редакторе.

3) Пункт "Сведения" показывает Информационное окно для данного родственника.

4) Пункт "Семьи" показвает Список семей со всеми семьями, в котором данный родственник является членом (родителем или ребёнком).

5) Пункт "Вырезать" копирует данного родственника (или группу выделенный родственников) в буфер обмена и удаляет его (или группу).

6) Пункт "Кпировать" копирует данного родственника (или группу выделенный родственников) в буфер обмена.

7) Пункт "Вставить" имеется только в выпадающем меню и вставляет содержимое буфера обмена левым верхним углом в место щелчка. Учтите, что если вы скопировали большую группу родственников, в левом верхнем углу которой никого нет, то вы можете и не увидеть сразу результат вставки - сделайте видимым все дерево, чтобы увидеть результат.

8) Пункт "Родословная" открывает специальное окно, в котором показывает родословную данного родственника. См. Окно "Родословная"

9) Пункт "Переместить к детям" применяется при ручной расстановке родственников в дереве и помещает данного родственника (или группу выделенный родственников) в непосредственной близости выше его (их) детей. При таком перемещении меет смысл выделять обеих родителей.

9) Пункт "Переместить к родителям" применяется при ручной расстановке родственников в дереве и помещает данного родственника (или группу выделенный родственников) в непосредственной близости ниже его (их) родителей. При таком перемещении меет смысл выделять всех детей.


Окно «Родословная»

В этом окне показывается родословная одного родственника - предки и потомки, а также супруги и братья-сёстры. Этот «главный» родственник отмечен в родословной розовым фоном:

Вертикальное расположение родословной

Переключатели «ВЕРТ» и «ГОРИЗ» меняют расположение родословной - соответственно, вертикальное или горизонтальное:

Горизонтальное расположение родословной

Выпадающие списки «Потомки» и «Предки» позволяют задать количество показываемых поколений: от 0 до 6 и «Все». Если у рамки какого-то потомка (или предка) нарисована стрелка (как у Gillian CLARK или Elliott RUSSELL - см. рисунок), то это означает, что у этого потомка (предка) есть еще потомки (предки) - их можно увидеть, если увеличить количество показываемых поколений.

При каждом новом построении или изменении родословной «главный» родственник будет, по возможности, помещаться в центре окна.

Кнопки «+», «-», «1:1» и «Всё» позволяют регулировать масштаб изображения.

Кнопки «<» и «>» предназначены для навигации по «истории» показанных родословных - подобно кнопкам Назад и Вперёд в браузере Internet Explorer.

При нажатии правой кнопкой мыши на рамке какого-либо родственника появляется выпадающее меню с тремя пунктами:

«Родословная» - показывает родословную этого родственика в этом же окне. (А вернуться к предыдущей родословной можно кнопкой «<».)

«Общие дети» - этот пункт меню будет доступен только при щелчке на одной из супруг(ов) «главного» родственника. При этом выделяются красным цветом эта супруга и все их общие с «главным» родственником дети (а также потомки этих детей):

Пункт «Правка» вызывает данного родственника на редактирование в Редакторе.

И, наконец, кнопка «Сохранить» сохраняет родословную в файле. Родословная при этом предварительно переводится в «вертикальный» вид. Можно сохранить родословную, включив в неё как всех супруг(ов), так и одного по выбору, а также включить братьев-сестёр:

Например, сохраним родословную с одной супругой (Heather ROBERTS) и с братьями-сёстрами. Открыв полученный файл (E.WILSON_pedigree.rel) мы увидим на экране следующее:

После небольшой ручной правки получаем родословную, которую уже можно распечатать или конвертировать в рисунок для размещения в Интернете:

Оконная "лупа" работает для окна родословной точно также, так и для основного окна.

См. также:
Список родственников
Выпадающее меню


Быстрый поиск

Быстрый поиск родственников в дереве

Найти родственников (не семьи!) в дереве можно, не открывая диалогового окна поиска. Для этого в главном окне программы в правом верхнем углу есть текстовое поле "Быстрый поиск...". Введите туда слово и нажмите Ввод. Программа найдет всех родственников, в которыых встречается это слово и выведет их в Списке родственников. Быстрый поиск имеет следующие особенности:
- поиск ведется во ВСЕХ полях записей.
- если введены несколько слов (через пробелы), то поиск ведется по всем словам во всех полях записей. То есть найденным считается родственник, у которого встречаются все заданные слова.

Проще говоря, быстрый поиск соответстуют поиску с помощью диалогового окна "Поиск":
- по нескольким ключевым словам,
- во всех полях,
- с логикой поиска "И".

В ключевых словах можно использовать простые знаки подстановки. См. Диалоговое окно "Поиск".


Как...

Как создавать, изменять и удалять элементы генеалогического дерева.


Как создать новое дерево (файл).

См.: Меню "Файл" - "Создать".


Как создать нового родственника

Создать нового родственника можно следующим способом:

  1. В свободном месте, где вы хотите поместить нового родственника, нажмите ПРАВУЮ кнопку мыши и выберите "Новый родственник" из выпадающего меню.

В появившемся окне Редактора введите имя, пол, даты жизни и другие необходимые элементы.

Нажмите ОК (или Отмена, если передумали). Новый родственник появится в том месте, где вы щелкнули мышкой

См. также: Редактирование родственника.


Как изменить сведения о родственнике

Изменить сведения об уже существующем родственнике можно следующими способами:

  1. Наведите мышку на рамку нужного родственника, нажмите ПРАВУЮ кнопку мыши и выберите "Изменить" из выпадающего меню.

    2. ИЛИ
  2. В Списке родственников (меню "Вид" - "Список родственников") выделите нужного родственника и нажмите кнопку "Правка".

В появившемся окне Редактора измените необходимые элементы.

Нажмите ОК (или Отмена, если передумали).

Кнопка "Удалить" предназначена для удаления данного родственника из дерева.

См. также: Редактирование родственника.


Как удалить уже существующего родственника

Удалить уже существующего родственника (или нескольких родственников) можно следующими способами:

  1. Выделите нужного родственника (или группу родственников) и нажмите клавишу Del на клавиатуре.

    2. ИЛИ
  2. Выделите нужного родственника (или группу родственников) и выберите пункт "Удалить" в меню "Правка".

    3. ИЛИ
  3. В Списке родственников (меню "Вид" - "Список родственников") выделите нужного родственника и нажмите кнопку "Удалить".
    В появившемся диалоговом окне нажмите ОК (или Отмена, если передумали).

См. также: Копирование - вырезание - вставка - удаление


Как перемещать родственников.

Перемещать родственников можно просто мышкой - щелкните на рамке родственника левой кнопкой и перетащите на новое место. Если перетаскиваемый родственник будет в группе выделенных, то переместится вся группа.

Если в дереве выделены один или несколько родственников, то перемещать их можно также с помощью клавишей-стрелок. Каждое нажатие будет перемещать выделенную группу на 10 пикселей. Если при этом держать нажатой клавишу Ctrl, то шаг перемещений уменьшится до 1 пикселя, а если клавишу Shift - то увеличится до 100 пикселей.
Примечание: величина перемещения указана в экранных пикселях, т.е. это видимое перемещение. Реальное перемещение рамок будет зависеть от установленного масштаба, например, в масштабе 1:25 перемещения на 1 экранный пиксель будет равно перемещению рамок на 25 пикселей.

Если при перемещении какие либо рамки выйдут за левый или верхний край экрана, то все дерево автоматически сдвинется вправо или вниз - так, чтобы все рамки родственников всегда были в видимой части экрана.

Другие типы перемещений - выравнивания, распределения и перестановка - рассматриваются в соответствующих пунктах меню "Вид":
Меню "Вид" - "Выровнять"
Меню "Вид" - "Распределить"
Меню "Вид" - "Поменять местами"


Как создать новую семью

Для создания новой семьи необходимо иметь как минимум два члена этой семьи.

  1. Выделите необходимых родственников - членов новой семьи и выберите "Новая семья из выделенных" в меню "Правка".
  2. В появившемся окне Редактора "Новая семья":

    Используя кнопки "Муж...", "Жена...", "Дети...", выберите из выпадающих списков отца (мужа) и мать (жену), добавьте детей.

    ИЛИ

    Нажмите кнопку "Авто создание".
    В этом случае программа автоматически создаст семью из выделенных родственников, ориентируясь только на их положение. Для этого нужно расположить их так, чтобы родители были выше и находились примерно на одном уровне по высоте, а дети - ниже.

    Семья будет создана автоматически.
    Если в верхнем ряду окажутся трое или больше родственников, то программа откажется создавать такую семью - трёх родителей не может быть.
    Если выделенных родственников всего двое и они оба находятся в одном ряду, то программа попросит уточнить: что это: муж и жена (без детей) ИЛИ братья-сестры (без родителей)?
    Если выделенных родственников больше двух и они все находятся в одном ряду, то это понятно, что все они братья и сестры, и программа так и сделает из них семью, где только дети и не указаны родители.

    Нажмите ОК (или Отмена, если передумали).

См. также: Редактирование семьи.


Как изменить сведения о семье

Изменить сведения об уже существующей семье можно следующим способом:

  1. В Списке семей (меню "Вид" - "Список семей") выделите нужную семью и нажмите кнопку "Правка".
  2. В появившемся окне Редактора измените необходимые элементы.
  3. Нажмите ОК (или Отмена, если передумали).

Кнопка "Удалить" предназначена для удаления данной семьи из дерева - при этом сами родственники-члены семьи НЕ БУДУТ удалены.

См. также: Редактирование семьи.


Как удалить существующую семью

Удалить уже существующую семью, не удаляя ее членов, можно единственным способом:

  1. В Списке семей (меню "Вид" - "Список семей") выделите нужную семью и нажмите кнопку "Удалить".
  2. В появившемся диалоговом окне нажмите ОК (или Отмена, если передумали).
    При удалении семьи из дерева сами родственники-члены семьи НЕ БУДУТ удалены - будут удалены только их семейные связи.

Семья также автоматически удаляется, если удалены все ее члены или все, кроме одного.

См. также: Копирование - вырезание - вставка - удаление


Как выделять родственников и семьи

Родственники выделяются мышью с использованием клавиши Shift: нажмите клавишу Shitt и, держа её нажатой, нажмите левой кнопкой мыши в свободном от рамок родственников месте и протащите (держа нажатой кнопку мыши) по диагонали. Все родственники, которые попали в образовавшийся прямоугольник, будут выделены - их рамки станут красного цвета.

Добавить в выделенное или исключить родственников из выделенного можно также с помощью клавиши Shift - держите ее нажатой и снова выделите группу родственников (или щелкните по рамке одного родственника) - новые родственники будут добавлены в выбранное или исключены из него в зависимости от того, были ли они уже выбраны.

Убрать выделение со всех выделенных родственников можно следующими способами:
- нажать клавишу Пробел,
- нажать Shift + Пробел,
- выбрать пункт меню "Правка" - "Снять выделение".

Строго говоря, саму семью в дереве выделить нельзя - можно только выделить всех её членов. В Списке семей, например, можно выбрать семью, а затем выделить всех ее членов, нажав кнопку "Выделить: эту семью". См.: Список семей.


Копирование - вырезание - вставка - удаление.

Чтобы скопировать/вырезать/удалить одного родственника можно щелкнуть на рамке родственника правой кнопкой мыши и выбрать соответствующий пункт меню.

Чтобы скопировать/вырезать/удалить несколько родственников, необходимо сначала выделить их, затем или а) щелкнуть на рамке одного из выделенных родственников правой кнопкой мыши и выбрать соответствующий пункт выпадающего меню или б) выбрать соответствующий пункт из меню "Правка".

Вставить родственника или группу родственников из буфера обмена можно только через выпадающее меню - щелкните правой кнопкой мыши на свободном от рамок месте и выберите пункт "Вставить" - содержимое буфера обмена будет вставлено таким образом, что левый верхний угол родственника или всей группы будет находиться в месте щелчка.

Удалить семью можно только в Списке семей - см. Список семей. При этом удаляются только семейные связи, а не сами члены семьи.

Особенности операций копирования, вырезания, вставки и удаления.

Все эти операции производятся только над родственниками. Единственное исключение - удаление семьи в Списке семей.
При всех этих операциях поддерживается логическая целостность ссылок. Вот как это происходит при разных операциях:

    При копировании одного родственника:
  • Выбранный родственник копируется в буфер обмена и у этой копии удаляются все семейные связи.
  • Все записи общего пользования, на которые у этого родственника есть ссылки, также копируются в буфер обмена, а у копии сохраняются ссылки на них.
    При копировании группы родственников:
  • Копии выбранных родственников помещаются в буфер обмена.
  • У всех этих копий проверяются все семейные связи. Если эти связи - между членами данной группы, то они сохраняются, а копии этих семей также помещаются в буфер обмена.
  • У каждой копии семьи проверяются ссылки на всех её членов, и, если члены эти не попали в данную группу, то ссылки на них удаляются.
  • Все записи общего пользования, на которых у скопированных родственников и семей есть ссылки, также копируются в буфер обмена, а у копий сохраняются ссылки на них.
    При удалении одного родственника:
  • Выбранный родственник удаляется, а у всех семей, где он был членом, удаляются ссылки на него.
  • Если у какой-либо семьи в результате этого остается менее 2-х членов, то такая семья также удаляется.
    При удалении группы родственников:
  • Выбранные родственники удаляются, а у всех семей, где они были членами, удаляются ссылки на них.
  • Если у какой-либо семьи в результате этого остается менее 2-х членов, то такая семья также удаляется.
    При удалении семьи:
  • Семья удаляется из дерева.
  • У всех членов семьи удаляются ссылки на эту семью.
    Вырезание является комбинацией двух вышеприведенных операций.
    При вставке из буфера обмена:
  • Содержащиеся в буфере обмена родственники и семьи добавляются в дерево с новыми идентификационными номерами (ID).
  • Относительно записей общего пользования, которые были связаны с копируемыми родственниками и семьями и потому попали в буфер обмена, применяются следующие правила:
    1) Если в том дереве, куда вставляется содержимое буфера, нет записи общего пользования с таким же ID (это ведь может быть другой файл!), то запись из буфера добавляется в дерево;
    2) Если запись с таким ID существует, но содержимое её отличается от вставляемой, то запись из буфера также добавляется в дерево, но уже с новым ID;
    3) Если и ID и содержимое записей совпадают, то запись из буфера в дерево не добавляется - ссылки будут указывать на уже имеющуюся запись.


Как изменять масштаб.

Основной метод изменения масштаба: вращением колёсика мыши. При это центр изменения масштаба будет находиться там, где находится в данный момент курсор мыши.

Если нужно, чтобы в окне поместилось определенная область дерева, то следует охватить нажатой кнопкой мыши нужную область, держа нажатой клавишу Alt.

Для изменения масштаба можно также использовать меню "Вид". См.: Пункты меню "Вид" для изменения масштаба

См. также:
Меню "Вид" - "Предыдущий" и "Следующий"


Списки
Список родственников
Список семей
Список записей общего пользования


Список родственников

Список родственников показывается при выборе соответствующего пункта меню "Вид".

Он также вызывается для показа результата поиска и для показа членов семьи (кнопка "Члены..." в Списке семей).

Родственники в списке показываются в формате:
N) Фамилия, имя-отчество (даты жизни),
где N - номер по порядку.

В верхней части окна расположено поле быстрого поиска. При наборе в этом поле первых букв фамилии и, через пробел, имени, выделение в списке переходит на данную фамилию/имя. Например, если набрать "алек ник", то в списке выделится "Алексеев, Николай Петрович

Двойной щелчок мышью на строке списка выделяет данного родственника в дереве и, если в окне видна только часть дерева, перемещает дерево в окне так, чтобы выделенный родственник был показан в середине. При этом, если Информационное окно открыто, в нем показываются сведения об этом родственнике.

    На нижней панели:
  • Кнопка "Выделить" - выделяет родственника и показывает сведения о нем - точно так же, как двойной щелчок мышью.
  • Кнопка "Семьи..." - показывает в Списке семей все семьи, где данный родственник является членом. При этом первыми в списке идут семьи, где этот родственник является супругом (отцом или матерью), а затем - где он является ребенком.
  • Кнопка "Сведения" - показывает сведения о родственнике в Информационном окне, без его выделения.
  • Кнопка "Родословная" открывает специальное окно, в котором показывает родословную данного родственника. См. Окно "Родословная"
  • Кнопка "Правка" - вызывает родственника на редактирование в Редакторе.
  • Кнопка "Удалить" - удаляет родственника, предварительно предупредив об удалении.

Переключатель "Всегда сверху": если он включен, то окно Списка будет всегда оставаться поверх других окон.

См. также:
Меню "Правка" - "Поиск"
Список семей


Список семей

Список семей показывается при выборе соответствующего пункта меню "Вид".

Он также вызывается для показа результата поиска и для показа семей родственника (кнопка "Семьи..." в Списке родственников).

Семьи в списке показываются в формате:
N) И.О.Фамилия мужа + И.О.Фамилия жены (имена детей),
где N - номер по порядку.

В верхней части окна расположены:
Поле быстрого поиска. При наборе в этом поле первых букв фамилии мужа и, через пробел, фамилии жены (или жены и мужа - в зависимости от сортировки) выделение в списке переходит на данную семью. Например, если набирать "раст аза", то с списке выделится "В.Н.Расторгуев + В.М.Азарова".
Выпадающий список сортировки - по фамилиям мужа или по фамилиям жены. Формат показа семьи в списке при этом не меняется - муж всегда показывается первым.

Двойной щелчок мышью на строке списка выделяет данную семью (её членов) в дереве и, если в окне видна только часть дерева, перемещает дерево в окне и, при необходимости, уменьшает масштаб так, чтобы выделенная семья была показана полностью и в середине. При этом, если Информационное окно открыто, в нем показываются сведения об этой семье.

    На нижней панели:
  • Кнопка "Выделить" работает совместно с выпадающим списком "эту семью - с предками - с потомками" и с переключателем "с супругами":
    "эту семью" - выделяет только выбранную семью и показывает сведения о ней - точно так же, как двойной щелчок мышью;
    "с потомками" - выделяет выбранную семью и всех её потомков;
    "с предками" - выделяет выбранную семью и всех её предков.
    Если переключатель "с супругами" включен, то дополнительно выделяются все супруги членов семей.
  • Кнопка "Члены..." - показывает в Списке родственников всех членов данной семьи. При этом первым в списке идет муж (отец), вторым - жена (мать), а затем дети.
  • Кнопка "Сведения" - показывает сведения о семье в Информационном окне, без её выделения.
  • Кнопка "Правка" - вызывает семью на редактирование в Редакторе.
  • Кнопка "Удалить" - удаляет семью, предварительно предупредив об удалении. Члены семьи при этом не удаляются.

Переключатель "Всегда сверху": если он включен, то окно Списка будет всегда оставаться поверх других окон.

См. также:
Меню "Правка" - "Поиск"
Список родственников.


Список записей общего пользования

Список записей общего пользования показывается при выборе пункта "Общие записи" меню "Вид".

Он также вызывается для показа результата поиска.

В левой части окна показывается список записей в формате:
Тип записи: ID

В правой части - содержимое записи в виде дерева её элементов.

    На нижней панели:
  • Кнопка "Создать:" - создает новую запись типа, указанного в выпадающем списке по соседству, вызывая Редактор.
  • Кнопка "Правка" - вызывает запись на редактирование в Редакторе.
  • Кнопка "Удалить" - удаляет запись, предварительно предупредив об удалении, а также об имеющихся на эту запись ссылках.
  • Кнопка "Сведения" - показывает сведения о записи в Информационном окне.
  • Кнопка "Ссылки" - показывает все записи (родственников, семьи, заголовок файла и общие записи), в которых есть ссылки на данную запись. При этом становится доступной кнопка "Назад", с помощью которой можно вернуться к первоначальному списку записей общего пользования.

Переключатель "Всегда сверху": если он включен, то окно Списка будет всегда оставаться поверх других окон.


Редактор

Редактор предназначен для создания и редактирования записей генеалогического дерева (заголовок, родственники, семьи, записи общего пользования).

Все элементы представляются в редакторе схожим образом:
Слева располагается панель, на которой запись и ее элементы представлены в виде дерева (подобно структуре директорий). При выборе элемента мышкой на правой панели будет показано значение данного элемента, а в верхней части редактора - его описание.
Если значение элемента - это ссылка на другую запись (родственника, семью или запись общего пользования), то элемент при выборе выделяется красным цветом - это означает, что на нем можно сделать двойной щелчок, и на редактирование будет вызвана та запись, на которую элемент ссылается. Вернуться к предыдущей записи можно при помощи кнопки "Назад". Таким образом можно "пройтись" по всем записям, связанным ссылками.
При щелчке на элементе правой кнопкой мыши появится выпадающее меню из трёх пунктов:
Добавить к ... - к элементу можно добавить элемент следующего уровня, какой именно - покажет выпадающий список. Если этот пункт недоступен, то это означает, что либо элемент не может содержать другие элементы, либо их количество уже достигло максимума.
Изменить ... - изменяет значение выбранного элемента. Если этот пункт недоступен, то это означает, что либо элемент имеет неизменяемое значение, либо не имеет никакого - такой элемент только содержит другие элементы, но сам не имеет значения (Исключением из этого правила является элемент Ссылка - у него нет значения, но его можно вызвать этим приемом на редактирование в Редактор ссылки со всеми его элементами).
Удалить ... - удаляет выбранный элемент. Недоступность этого пункта означает, что количество этих элементов уже минимально. Удалить элемент самого верхнего уровня, т.е. саму запись, в Редакторе нельзя.
Элементы располагаются в записи в порядке, определенном степенью их "необходимости", т.е. сверху располагаются самые необходимые и наиболее часто используемые элементы. Вновь созданные элементы будут добавляться в соответствии с этим порядком. Исключение составляют элементы, определенные пользователем - они всегда добавляются в конец.
Однотипные элементы можно расположить в любом нужном порядке, перемещая их кнопками "Вверх" и "Вниз" по отношению друг к другу.

Количество разных типов элементов, которые можно добавить к записи или ее элементам порой очень велико и может смутить неподготовленного пользователя, поэтому доступ к наиболее важным элементам вынесен на нижнюю панель редактора в виде кнопок "быстрого доступа". Можно сказать, что редактирование с помощью выпадающего меню - это "профессиональный" уровень, дающий доступ ко всем свойствам записи, а Панель быстрой правки - это "базисный" уровень, дающий быстрый доступ только к нескольким, но зато самым необходимым элементам.
Примечание: Кнопка быстрой правки "Комментарий" работает только с одним, первым комментарием. Чтобы создать еще один комментарий, или вызвать на редактирование другие комментарии, необходимо использовать выпадающее меню на панели дерева элементов записи.

При создании или редактировании элемента появляется специальное окно редактирования. Его вид зависит от типа значения элемента, определенного в шаблоне элемента:

Тип значения | Окно редактирования
пусто | Нет окна редактирования, элемент просто создается.
строка | Однострочное поле ввода.
текст | Многострочное поле ввода.
ссылка | Выпадающий список всех записей, на которые может ссылаться данный элемент.
список | Выпадающий список всех значений, которые может принимать данный элемент.
шаблон | Внешне выглядит также, как однострочное поле ввода, но можно ввести только то значение, которое задано шаблоном. Пример: Элемент "Количество детей" в семье - может принимать только числовое значение от 1 до 999, все другие будут отвергаться.
и так далее... Для некоторых типов элементов окна редактирования имеют несколько полей ввода. Кнопки быстрого редактирования также вызывают свои специальные окна редактирования. Например, кнопка "Рожд. и смерть..." у родственника вызовет окно редактирования, в котором можно задать как даты, так и места рождения и смерти.
Каждое окно редактирования имеет свою кнопку "Помощь", нажав на которую можно получить справку, как редактировать тот или иной элемент.

Изменения в записи вносятся только после нажатия на кнопку ОК. При этом запись сначала проверяется на наличие пустых элементов и на выполнение некоторых специальных условий, например, родственник должен иметь, по крайней мере, или имя, или фамилию, или дату рождения/смерти, иначе он не сможет быть показан в дереве.

См. также:
Редактирование родственника
Редактирование семьи
Редактирование записи общего пользования
Редактирование заголовка файла
Создание и редактирование ссылок


Редактирование заголовка файла

Редактирование заголовка файла в Редакторе записей

По сравнению со стандартом GEDCOM в заголовок файла добавлены следующие пользовательские тэги:

  1. "Имя" (тэг _TITL) - однострочное поле, название дерева, которое записано в файле.
  2. "Фоновый цвет" (тэг _BG) - фоновый цвет дерева.
  3. "Директория документов" (тэг _MDIR) - директория на локальном компьютере, в которой хранятся любые другие файлы, на которые в данном дереве имеются ссылки (тэги OBJE).
    Директория документов может быть:
    а) поддиректорией по отношению к директории, в которой находится сам файл дерева. Например, в некоторой записи имеется элемент Ссылка, элемент Файл которой имеет значение "John Smith.jpg". Тогда, если Директория документов в заголовке имеет значение "SmithTreeFiles", а файл дерева находится в директории "C:\My Documents\Gedcom Files", то полный путь к файлу, на который будет указывать данная ссылка, будет "C:\My Documents\Gedcom Files\SmithTreeFiles\John Smith.jpg", т.е. Директория дерева + Директория документов + имя файла.
    b) Абсолютной директорией, например "C:\My Documents\photos". В этом случае файл будет искаться по пути "C:\My Documents\photos\John Smith.jpg" независимо от того, в какой директории находится файл дерева.
    Очевидно, что способ a предпочтительнее, т.к. при переносе файла дерева с одного компьютера на другой достаточно перенести с ним поддиректорию документов, и все ссылки будут работать.
    Директория документов не может быть удаленной, т.е. быть типа "http://www.smithgenealogy.com/trees/files". Если сам файл дерева находится на удаленном сервере, например, по адресу "http://www.smithgenealogy.com/trees/smith.rel", то Директория документов в нём может быть указана как поддиректория - просто "files".

    Директорий документов в заголовке может быть указано несколько, тогда поиск файлов будет осуществляться в порядке очередности - если по первому адресу файл не найден, то будет сделана попытка найти его в следующей директории и т.д.

Если ссылка на документ не является абсолютной, то последовательность, в которой программа ищет документ, следующая:

  1. Просматривается директория, где находится сам файл дерева;
  2. Последовательно просматриваются Директории документов, если они заданы;
  3. Просматривается директория "Мои документы";
  4. Просматривается директория "Мои документы\Мои рисунки";
  5. Просматривается директория "Мои документы\Мои видеозаписи";
  6. Просматривается директория "Мои документы\Моя музыка";
  7. Если документ нигде не найден, выдается сообщение...

В заголовок также можно добавить Ссылки (тэг OBJE), указывающие на документы, относящиеся ко всему дереву в целом. Тэги OBJE в заголовке не предусмотрены стандартом GEDCOM, но автор решил добавить такую возможность, как логически необходимую - почему все другие записи дерева могут иметь ссылки на документы, а само дерево - нет?

Тэг SCHEMA поддерживается специальным образом - через Редактор пользовательских тэгов.
См. О "расширенной" поддержке пользовательских тэгов.

Примечание: при импорте GEDCOM файла все элементы заголовка файла остаются такими, какими они были в исходном файле. При сохранении в формате *.rel заголовок записывается в файл таким, какой есть. Но при последующем экспорте такого файла в формат GEDCOM:

  1. Программа проверяет наличие в заголовке элементов, которые обязательны согласно стандарту GEDCOM: "Автор файла" (тэг SUBM) и "Кодировка" (тэг CHAR). Если их нет, программа предлагает создать их и повторить экспорт.
  2. Элементы "Программа-создатель" (тэг SOUR), "Программа-получатель" (тэг DEST) и "GEDCOM" (тэг GEDC) заменяются на новые (или добавляются, если их нет). Эти новые элементы:
    Программа-создатель = "Relatives"
    Программа-получатель = "Relatives"
    GEDCOM = 5.5 (версия)
  3. Дата (тэг DATE) и время (тэг TIME) устанавливаются на текущую дату и время.

См. также:
Редактор
Создание и редактирование ссылок


Редактирование родственника

Редактирование родственника в Редакторе записей

Для быстрого доступа к основным элементам записи используйте кнопки Имя..., Рожд. и смерть..., Комментарии..., Ссылки... и радоикнопки установки пола ?, М и Ж.

При нажатии на кнопки Добавить в семью как: будет вызвано диалоговое окно со списком семей дерева, в которое данный родственник будет добавлен как супруг или ребенок. При этом, если добавляется супруг, а в этой семье уже есть супруг такого же пола, то он заменяется, а не добавляется.

При нажатии на кнопку ОК Редактор проверяет, задано ли имя, фамилия и даты рождения/смерти и, если ни одного из этих элементов нет, не позволяет создать такого родственника.
Примечание: Если фамилия не задана, то в полном имени родственника (например, "А.И.Иванов" или "Иванов, Алексей Иванович") будет указано "неизв." вместо фамилии.

См. также:
Редактор
Создание и редактирование ссылок


Редактирование семьи

Редактирование семьи в Редакторе записей

Для быстрого доступа к основным элементам записи используйте кнопки "Муж...", "Жена...", "Дети...", "Бракосочетание...", "Комментарии..." и "Ссылки...".

Кнопки "Муж..." и "Жена..." вызывают диалоговые окна со списками мужчин или женщин соответственно. При этом если Редактор вызван в меню "Правка" - "Новая семья из выделенных", то в списке будут только мужчины/женщины из числа выделенных родственников - это позволяет уменьшить размер списка и облегчить поиск нужного родственника.

Кнопка "Дети..." вызывает диалоговое окно редактирования детей:

Кнопки "Добавить" и "Правка" вызывают диалоговые окна со списками родственников. При этом если Редактор вызван в меню "Правка" - "Новая семья из выделенных", то в списке будут только родственники из числа выделенных.

Кнопки "Вверх" и "Вниз" позволяют перемещать детей по списку. Реально порядок детей в списке никак не отражается на их визуальном положении в дереве. Стандарт GEDCOM рекомендует располагать детей в порядке старшинства - старшие дети в начале списка.
Примечание: порядок следования детей можно изменить также в дереве элементов кнопками "Вверх" и "Вниз".

При нажатии на кнопку "ОК" Редактор проверяет количество членов семьи и, если оно меньше двух, не позволяет создать такую семью.

См. также:
Редактор
Создание и редактирование ссылок


Редактирование записи общего пользования

Редактирование записи общего пользования в Редакторе записей

При редактировании записи общего пользования панель быстрой правки не содержит никаких кнопок, т.к. в разных записях разные элементы имеют первоочередное значение.

См. также:
Редактор
Создание и редактирование ссылок


Создание и редактирование комментариев

Диалоговое окно «Комментарии...» появлется при нажатии на кнопку «быстрого доступа» «Комментарии...» в окне Редактора. В этом окне Вы можете отредактировать все комментарии данной записи сразу (другой путь работы с комментариями - это обычное поэлементное создание/редактирование комментариев в дереве элементов записи).

Комментарий (тэг NOTE) имеет только один возможный элемент:

  1. Ссылка на запись общего пользования типа Источник информации (тэг SOUR). Необязательный элемент.Обратите внимание, что Комментарий не имеет элемента Источник информации обычного, текстового типа. В стандарте GEDCOM это объясняется тем, что указание на источник рекомендуется включать в сам текст комментария.

Элементы диалогового окна «Комментарии...»

1) В верхней части окна расположен список первых строк всех комментариев данной записи. При выборе строки в этом списке, полный текст данного комментария показываются в окне ниже.

2) Справа от списка - панель с кнопками:

Добавить - в зависимости от того какая радиокнопка ниже включена:

  1. Текст: открывает Редактор комментария для создания новой текстовый ссылки;
  2. Запись: открывает список всех имеющихся в данном файле записей общего пользования типа Комментарий для выбора нужной записи. Если таких записей в файле нет, то будет выдано предупреждение.

Правка - в зависимости от типа комментария (техт или ссылка) вызывает комментарий на редактирование в текстовом Редакторе комментария или показывает список всех имеющихся в данном файле записей общего пользования типа Комментарий для выбора новой записи;

Удалить - удаляет выбранный комментарий;

Вверх и Вниз позволяют изменить порядок следования комментариев, перемещая их по списку.

3) Назначение кнопок Сохранить, Отмена и Помошь - без комментариев...

См. также:
Редактор
Структура данных программы


Создание и редактирование ссылок

Диалоговое окно «ССЫЛКИ на фотографии, документы, веб-страницы...» появлется при нажатии на кнопку «быстрого доступа» «Ссылки...» в окне Редактора. В этом окне Вы можете отредактировать все ссылки данной записи сразу (другой путь работы с ссылками - это обычное поэлементное создание/редактирование ссылок в дереве элементов записи).

Ссылка (тэг OBJE) имеет 4 возможных элемента:

  1. Заголовок (тэг TITL) документа. Обязательный элемент. Эти заголовки пользователь будет видеть в списке ссылок в информационном окне записи.
  2. Файл (тэг FILE) - полный локальный или удаленный (сетевой) адрес документа. Обязательный элемент. Адрес может быть абсолютным или относительным. Файлы, имеющие абсолютный адрес (типа C:\Works\Archive\Photos\Petrov.jpg, т.е. указывающие на полный путь к файлу), ищутся непосредственно по указанному адресу, тогда как относительные (типа Photos\Petrov.jpg) ищутся сперва в директории, где находится сам файл дерева, затем в директориях документов, затем в системных директориях документов и медиа-файлов ("Мои документы", "Мои рисунки", "Мои видеозаписи" и "Моя музыка").

    Если файл дерева открыт с удаленного адреса (например, http://www.genealogysoft.com/ru/examples/sample-ru-1.rel), то файлы с относительными адресами будут искаться на том же сервере, откуда был загружен файл дерева. Например файл с адресом "media/london.jpg", будет искаться по адресу http://www.genealogysoft.com/ru/examples/media/london.jpg

    Ссылки могут указывать не только на файлы, но и на целые директории. Это очень удобная форма представления целой коллекции документов в одной ссылке. Представьте, что имеется много документов, относящихся к какому-то одному родственнику. Тогда вместо того, чтобы создавать ссылку для каждого документа, можно просто собрать все документы, относящиеся к данному родственнику, в одной директории и создать только одну ссылку на эту директорию. Теперь можно дополнять директорию новыми документами, переименовывать файлы, удалять их, не меняя при этом самой ссылки. В Информационном окне такая ссылка может быть открыта так же, как любой другой документ, и пользователь увидит перед собой сразу все документы в одном окне системного Проводника.

    Внимание! Если Вы размещаете какие-либо файлы документов на сервере, старайтесь избегать в именах файлов нелатинские (не-ASCII) символы и пробелы! Кодировка, в которой сервер будет хранить имя файла с нелатинскими символами, чаще всего неизвестна, и потому заранее невозможно предугадать в какой кодировке надо кодировать имя файла в запросе к серверу. Программа «Родственники» не делает никаких предположений о кодировке имен сетевых ресурсов и посылает запросы на получение файлов "как есть", не кодируя их. Поэтому единственный способ, которым в этой программе можно загрузить ресурс, в имени которого имеются нелатинские буквы и/или пробелы, следующий:
    Предположим, Вы знаете, что кодировка, в которой сервер хранит имена файлов с русскими буквами - KOI8-R (обычная кодировка для веб-серверов Apache). Имя вашего файла - тест.jpeg. В этом случае имя файла в ссылке должно выглядеть так: %D4%C5%D3%D4.jpeg, где каждая русская буква заменена на последовательность %XX, где XX - шестнадцатеричный код буквы в кодировке KOI8-R (в привычной кириллической Windows кодировке это имя будет выглядеть как ФЕУФ.jpeg). Полный адрес файла в ссылке может выглядеть в этом случае, например, так: http://genealogysoft.com/ru/examples/%D4%C5%D3%D4.jpeg (такой файл реально существует - можете загрузить его). Если в имени файла есть пробелы, то их нужно заменить на %20 (а не символ "+", как этого делается в URL encoding). Таким образом, в программе «Родственники» имена файлов сетевых ресурсов должны храниться в ссылках уже закодированными.
  3. Формат (тэг FORM) документа - это в действительности расширение его файла ("jpg", "gif", "wav", "ged", "rel" и т.п.). Необязательный элемент, оставлен в целях совместимости с GEDCOM стандартом и другими генеалогическими программами, которые могут использовать расширение файла для определения программы, ассоциированной с данным типом документа. Программа «Родственники» старается определить формат документа по его расширению в тот момент, когда Вы вводите имя файла, пользуясь для этого списком форматов в файле Extentions.txt, который, кстати, пользователь может дополнять. Пользователь может также ввести свой формат.
  4. Комментарий (тэг NOTE) к ссылке. Необязательный элемент. Комментариев может быть несколько, и они могут быть как ссылками на записи-комментарии общего пользования, так и встроенными комментариями.

Элементы диалогового окна «ССЫЛКИ...»

1) В верхней части окна расположен список заголовков всех ссылок данной записи. При выборе заголовка в этом списке, остальные элементы данной ссылки показываются ниже: Адрес (Файл), Комментарии и Формат.

2) Справа от списка заголовков - панель с кнопками:
Добавить - открывает Редактор ссылки (см. ниже) для создания новой ссылки;
Правка - вызывает на редактирование в Редакторе ссылки;
Удалить - удаляет выбранную ссылку;
Вверх и Вниз позволяют изменить порядок следования ссылок, перемещая их по списку.

3) Назначение кнопок Сохранить, Отмена и Помошь - без комментариев...

Диалоговое окно «Редактор ссылки», в котором создаются/редактируются отдельные ссылки, имеет следующие элементы интерфейса:

1) Текстовое поле Имя (Заголовок) ссылки. Длина имени может быть любой, но желательно ограничить её 20-40 знаками, т.к. список этих заголовков будет показываться в информационном окне.

2) Текстовое поле Адрес (Файл) ссылки. Адрес не имеет ограничения по длине. Справа от этого поля расположена кнопка Найти... с помощью которой можно найти нужный файл.

3) Ниже, обведенный рамкой, расположен раздел Комментариев к ссылке:

  1. Список комментариев в центре показывает первые 40 букв комментария, если это встроенный комментарий или идентификатор записи, если это ссылка на запись-комментарий общего пользования.
  2. Справа от списка - панель с кнопками, назначение которых подобно кнопкам окна «ССЫЛКИ...» - редактирование, удаление комментариев, перемещение их по списку.
  3. Слева от списка - кнопка Добавить для создания нового комментария. Тип комментария (обычный встроенный текстовый комментарий или ссылка на запись общего пользования) определяется переключателями Обычный - Запись.
    При создании обычного комментария его содержимое вводится в обычное текстовое поле, а при создании комментария-ссылки будет предложен список всех записей этого типа для выбора.
  4. При выборе комментария в списке его полное содержимое будут показано в текстовом поле ниже. Причем, если это ссылка на запись-комментарий, то эта запись будет показана в виде дерева элементов.
  5. При вводе адреса (файла) ссылки программа автоматически определяет расщирение файла документа и, если он ей знаком (т.е. имеется в списке Extentions.txt, то показывает его в поле Формат. Пользователь может изменить этот формат или вовсе убрать его.
  6. Назначение кнопок Сохранить, Отмена и Помошь - без комментариев...

См. также:
Редактор
Структура данных программы
Медиа Мастер


Меню "Файл"

Меню "Файл" содержит обычные для этого меню пункты создания нового файла, открытия файла, сохранения, импорта-экспорта и т.п.


Меню "Файл" - "Создать"

Меню "Файл" - "Создать" открывает диалог создания нового файла.

После нажатия кнопки "Создать" программа проверит, существует ли уже указанный файл, если да - выдаст предупреждение. Реально новый файл как таковой не создается, он будет записан только после первого сохранения файла. Указание нового файла на самом деле нужно лишь для того, чтобы программа "знала", в какую директорию будет записан новый файл, чтобы при создании Директорий документов, а также ссылок на документы можно было определить положение этих документов относительно самого файла дерева.

О Директориях документов смотрите: Редактирование заголовка файла.


Меню "Файл" - "Открыть/Сохранить"

Меню "Файл" - "Открыть", "Сохранить", "Сохранить как...", "Недавние файлы:" - работают, как во всех программах Windows. Программа "Родственники" имеет собственный формат хранения файлов с расширением ".rel".

Файл можно загрузить не только с компьютера, но и из Интернета. Интернет-адрес файла при этом нужно указывать полностью, например, так: http://genealogysoft.com/ru/examples/sample-ru-1.rel (это реальный адрес - можете попробовать загрузить его).

При загрузке по протоколу ftp адрес файла должен содержать также логин и пароль следующим образом:
ftp://логин:пароль@ftp.sample.com/dir/subdir/treefile.rel

Пункт меню "Сохранить выделенное как..." отличается тем, что позволяет сохранить только выделенную часть дерева. Это аналогично созданию нового файла и копирования в него части дерева, за исключением того, что при сохранении заголовок дерева останется такой же, а при копировании-вставке в новый файл будет создан новый заголовок.

Обычно у больших деревьев весьма большое пространство в левом верхнем угла дерева остается свободным от рамок родственников. Чтобы не показывать в первый момент после открытия файла это пустое поле, программа подбирает масштаб изображения так, чтобы в правом нижнем углу экрана была видна хотя бы часть дерева.


Диалоговое окно "Импорт из GEDCOM 5.5 файла"

Меню "Файл" - "Импорт из:" - "GEDCOM 5.5 файл"

Элементы диалогового окна "Импорт GEDCOM файла":

Переключатель "Если найдена неполная семья:" определяет действия, которые необходимо предпринять программе, если в GEDCOM файле обнаружена неполная семья. Неполная семья - это семья, для которой указан только один член - только муж/отец, только жена/мать или только ребенок. По идее, такие семьи не должны существовать, однако многие генеалогические программы допускают их создание. Обычно в таких записях нет никакой полезной информации, поэтому их можно удалить. Данная программа предлагает выбор:

  1. "Создать недостающих членов" - к неполной семье будет добавлены формальные члены семьи с именем "незв.". Если в неполной семье есть только муж, будет добавлена жена, если только жена - добавлен муж, а если только ребенок - будут добавлены оба родителя. В этом случае гарантируется, что вся другая информация о семье будет сохранена при импорте.
  2. "Удалить её" - неполная семья будет удалена (её единственный известный член, конечно же, удален не будет). В этом случае информация, которую содержала эта семья, будет показана в специальном сообщении по окончании импорта - если вы найдете, что эти сведения полезны (если они вообще будут присутствовать), то просто повторите импорт с опцией "Создать недостающих членов".

Флажок "Вставлять пробел перед строкой CONC" отражает другую проблему с GEDCOM файлами. Дело в том, что согласно стандарту GEDCOM длинные строки текста перед записью в файл должны разбиваться на "куски" не более 248 символов. Каждый такой "кусок" в файле помечается тэгом CONC (concatenation), чтобы при чтении можно было собрать куски обратно в цельный текст. Причем, согласно стандарта GEDCOM, разбиение должно делаться только внутри слов. Однако немногие программы делаю это - вместо этого они делаю разрывы по пробелам, т.е. между словами. Поэтому при импорте GEDCOM файлов всегда встает вопрос: вставлять пробел между кусками (тогда в "правильных" файлах появятся пробелы посреди слов), или не вставлять (тогда в "неправильных" файлах слова сольются)? Поскольку невозможно заранее определить, какой файл, "правильный" или "неправильный" вам достался, в данной программе предлагается выбор - вставлять пробелы или нет. По умолчанию флажок включен (пробелы вставляются). Сделайте пробный импорт с этой опцией и просмотрите длинные тексты в записях - если в них встречаются слитые вместе слова, повторите импорт с отключенным флажком.

Флажок "Исправлять неправильные тэги" также отражает проблему несоответствия стандарту GEDCOM, согласно которому все тэги в файле должны быть или стандартными GEDCOM тэгами или пользовательскими тэгами, имена которых начинаются со знака подчеркивания '_'. Некоторые программы, однако, нарушают это правило и применяют свои собственные тэги, не начинающиеся с '_' (зачем они это делают, не совсем понятно - можно ведь просто сделать их пользовательскими, добавив к имени знак подчеркивания!). Если флажок "Исправлять неправильные тэги" включен, то такие неправильные тэги будут считаться пользовательскими с добавлением к их именам '_'. Если флажок выключен, то программа прекращает импорт, если встретит такой тэг.

Флажок "Удалять пустые элементы" позволяет задать режим удаления из записей пустых элементов - таких, которые не имеют никакой информации, а являются просто ненужным "балластом" в файле. В некоторых GEDCOM файлах таких элементов встречаются тысячи, существенно увеличивая размер файлов! Почему они там находятся? - это вопрос к авторам генеалогических программ, которые допускают создание таких пустых элементов...

В GEDCOM файлах могут встретиться и другие ошибки. Например, некоторые элементы ссылаются на записи, которых в самом деле не существует в файле. Такие элементы приходится удалять. Другая разновидность ошибок, связанных со ссылками - это когда элемент должен ссылаться на какую либо запись, но ссылки на самом деле нет - она пуста. Например, элемент "Супруг в семье" в записях типа "Родственник" должен ссылаться на семью, в которой данный родственник является супругом. Если такого рода ссылка пуста, то программа пытается восстановить её. Например, в случае с упомянутой уже ссылкой "Супруг в семье": если просмотреть все семьи в файле и среди них найдется такая, в которой элемент "Муж" (или "Жена") ссылаются на данного родственника, то можно предположить, ссылка на эту семью и была утеряна. Во всех подобных случаях следует, однако, проверить логическую целостность информации, о чем программа напомнит после импорта.
Кроме ошибок, вызванных несовершенными программами, встречаются и другие, причина которых - человеческие ошибки пользователей. Например, встречаются ситуации, когда ребенок в семье указан как муж или жена в этой же семье. Теоретически такое, конечно, возможно, но скорее всего, это сделано просто по невнимательности. Графическое представление дерева в данной программе помогает избежать таких ошибок, т.к. они сразу становятся видны.

Внимание! Автор программы старался предусмотреть распознавание как можно больше видов ошибок, однако он не гарантирует, что предусмотрел всё! Если вы встретите при импорте GEDCOM файлов какие-то новые ошибочные ситуации, пожалуйста, обращайтесь к автору. С другой стороны, примите во внимание тот факт, что файлы GEDCOM - это обычный текстовые файла - вы всегда можете открыть их в любом текстовом редакторе и попытаться исправить ошибку сами, тем более, что из сообщения об ошибке вы будете знать номер строки файла, в которой она произошла.

Выпадающий список "Кодировка" позволяет задать кодировку, с которой будет прочитан GEDCOM файл. Обычно следует сначала попытаться импортировать файл с опцией "Использовать кодировку из заголовка файла". Если в заголовке файла есть указание на его кодировку, то файл будет импортирован с ней, если нет - будет выдано сообщение - в этом случае повторите импорт, задав какую-нибудь кодировку из списка.

Введите в нижнее текстовое поле имя файла, или выберите кнопкой "Найти...". Нажмите ОК...
Если файл был предварительно экспортирован в GEDCOM формат из программы "Родственники", то в нем уже будет содержаться информация о расположении родственников в дереве, если нет - программа сделает автоматическую расстановку.
Если в файле встретились ошибки и неточности, то о них будет сообщено в диалоговом окне по окончании импорта. Список ошибок/неточностей можно просмотреть и сохранить в текстовом файле.

Обычно при импорте больших файлов весьма большое пространство в левом верхнем угла дерева остается свободным от рамок родственников. Чтобы не показывать в первый момент это пустое поле, программа подбирает масштаб изображения так, чтобы в правом нижнем углу экрана была видна хотя бы часть дерева.


Меню "Файл" - "Экспорт в:" - "GEDCOM 5.5 файл"

Экспортирует файл в формат GEDCOM 5.5. Перед экспортом программа проверяет наличие в Заголовке дерева двух обязательных (согласно стандарта GEDCOM) элементов: Кодировки (тэг CHAR) и Автора файла (тэг SUBM). Если их нет, программа попросит создать их.

При экспорте будет использоваться кодировка, заданная в Заголовке.

Вся графическая информация дерева при экспорте сохраняется в файле, потому при последующем импорте дерево будет показано в том виде, в котором вы его сохранили.


Диалоговое окно "Экспорт в HTML"

Меню "Файл" - "Экспорт в:" - "HTML файл" позволяет поместить информацию из дерева в текстовую интерактивную HTML страницу. Семейные связи между родственниками на этой странице будут представлены гиперссылками, так что пользователь будет иметь возможность навигации по всему генеалогическому дереву, а ссылки на документы и веб-страницы позволят открывать их прямо в браузере.

Элементы диалогового окна "Экспорт в HTML":

Переключатель "СОЗДАТЬ:" определяет форму выходного файла:

  1. Один большой файл - буден создан только один HTML файл, в котором будут помещены как списки родственников и семей, так и информация о них.
  2. Главный файл + файлы для каждой записи - в главном HTML файле будут помещены только списки родственников и семей, а информация о каждой записи - в отдельные HTML файлы в директорию имя_файла-infos. Учтите, что файлов может быть очень много (по одному на каждую запись - родственника, семью и запись общего пользования).

Переключатель "Включить информацию о родственнике/семье:" определяет, какая информация о записях будет включена:

  1. Всю (как в GEDCOM файле) - каждая запись будет показана со всеми своими элементами.
  2. Только комментарии и ссылки - соответственно, будут включены только комментарии и ссылки.

Переключатель "Экспортировать Все/Выделенное" указывает, все дерево или только его выделенная часть будет экспортирована. При этом, как и в случае сохранения выделенной части дерева, связи с родственниками и семьями, которые не попали в выделение, не будут импортированы, если не помечен флажок "Сохранить внешние ссылки"

Выпадающий список "Кодировка" позволяет задать кодировку выходного файла.

Примечание: Что если ваш файл содержит буквы не только русского алфавита, но и какого-нибудь другого неанглийского алфавита, например, турецкого? Не беспокойтесь, программа сохранит такой текст корректно, и в браузере турецкие буквы будут показываться как следует. При экспорте в HTML программа обрабатывает текст следующим образом:
1) Английские символы записываются как есть, по одному байту на букву;
2) Символы алфавита, кодировка которого задана (русские в нашем примере) - также однобайтными символами в соответствующей кодировке;
3) Символы всех остальных алфавитов преобразуются в последовательности "&#xxxx;", где xxxx - числовой код символа в системе UNICOD.
Так что на самом деле можно было бы вовсе не задавать кодировку - программа тогда закодирует все неанглийские буквы в &#-символах, и браузер их правильно покажет. Проблема только в том, что такой HTML файл по размеру будет в 5-6 раз больше...
Можно также экспортировать файл с кодировкой UTF-8, но это тоже увеличит размер файла в 1.5-2 раза.


Диалоговое окно "Экспорт в графику в HTML"

Меню "Файл" - "Экспорт в:" - "Графику в HTML"

"Графика в HTML" - это интерактивная гипертекстовая (HTML) страница с рисунком генеалогического дерева. Такую страницу можно просматривать в браузере, например, Internet Explorer или Netscape Navigator. Интерактивность её заключается в том, что рамки тех родственников, которые имеют комментарий или ссылки, реагируют на щелчки мышью показом сведений об этих родственниках.
Рисунок дерева для такой страницы сохраняется в файле графического формата GIF. Поскольку программа рисует дерево, в основном используя всего 5 цветов, такой формат позволяет сильно сжать файл. Так рисунок размером 1000 х 1000 пикселей занимает всего 10-15 килобайт, тогда как другие форматы - TIFF, PCX, JPEG - по крайней мере в 2 раза больше.
В отличие от печати дерева, где масштаб изображения определяется размером листа (листов) бумаги (изображение "подгоняется" под размер бумаги), при экспорте в графику выходной масштаб всегда "один-к-одному", т.е. размер выходного рисунка определяется размером дерева. К примеру, дерево примерно из 600-700 человек требует размера около 10000 х 4000 пикселей. Но браузеры показывают такие большие изображения очень неэффективно (или вообще не показывают), да и оперативной памяти для создания рисунка такого размера требуется очень много. По этой причине программа разбивает большие изображения на несколько меньших. Максимальный размер каждого рисунка, на который программа предлагает разбить общее изображение, равен 2400 х 1800 пикселей. Пользователь, тем не менее, может установить другой разиер, изменив количество ячеек таблицы, но не более 10 000 пикселей по каждой стороне.
Файлы рисунков сохраняются в поддиректории с именем [имя_html_страницы]_files.

Элементы диалогового окна "Экспорт в графику в HTML":

  1. Текстовые поля "Размер всего рисунка" показывают размеры изображения, необходимые для размещения на нем дерева в масштабе 1:1, плюс припуски по 50 пикселей с каждой стороны.
  2. Поля "Таблица" позволяют разбить большое изображение на ряд меньших, которые помещаются в ячейки таблицы на HTML странице. Процесс разбиения автоматически отражается в правой половине диалогового окна. При открытии окна программа сама вычисляет, на сколько частей необходимо разбить всё изображение, чтобы не превысить размера каждой ячейки 2400 х 1800 пикселей. Обычно никаких действий от пользователя здесь не требуется, если только он не желает сделать ячейки таблицы еще меньше - например, если браузер не желает показывать большие рисунки.
  3. В следующей строке показывается размер каждого рисунка, на которые разбито общее изображение.
  4. Группа переключателей "Фон" позволяет задать фон рисунка:
    Обычный - тот, который используется в самой программе;
    Белый - соответственно, белый;
    Прозрачный - фон рисунка будет отсутствовать - такое изображение можно накладывать на другие рисунки.
  5. Переключатель "Чересстрочный GIF" задает создание файла с так называемой "чересстрочной разверткой" - в браузере такое изображение будет как бы постепенно "проявляться" по мере загрузки файла.
  6. Переключатели "Экспортировать Все/Выделенное" позволяет выбрать: все дерево или только его выделенная часть будет экспортирована.
  7. Переключатель "Добавить персональные сведения" указывает, делать ли HTML страницу интерактивной. Если переключатель включен, то в вышеуказанной поддиректории [имя_html_страницы]_files будут созданы файлы, содержащие сведения о родственниках. Эти сведения будут показываться в отдельном окне браузера при нажатии мышкой на рамку соответствующего родственника.
  8. Выпадающий список "Кодировка" позволяет задать кодировку таких файлов с персональными сведениями. О кодировке см. также здесь.


Диалоговое окно "Печать"

Меню "Файл" - "Печать..."

Элементы диалогового окна "Печать":

  1. Список "Принтер" позволяет выбрать принтер.
  2. Список "Размер бумаги" позволяет выбрать размер бумаги.
  3. "Печатать в ..." позволяет выбрать вид печати - в цвете или в черно-белом виде.
  4. Список "Разрешение" позволяет выбрать разрешение печати.
  5. "Качество печати" позволяет выбрать качество печати, если у принтера есть такая опция.
  6. Список "Ориентация страниц" позволяет выбрать ориентацию печати, если выбранный принтер позволяет это.
  7. Пара списков "Страницы" позволяет выбрать количество страниц по горизонтали и вертикали (от 1 до 100), на которых будет распечатано дерево и таким образом, определить масштаб печати. При этом в правой половине диалогового окна будет показано, как именно будет размещено дерево на листах при печати.
  8. Поле "Размер печати" показывает общий размер печати (сумма всех листов бумаги). Список "дюйм-см-мм" позволяет выбрать единицы измерения этого поля.
  9. "Печатать... Все/Выделенное" позволяет выбрать все дерево или только его выделенная часть будет распечатана. Это будет отражено также в правой половине диалогового окна.


Диалоговое окно "Экспорт в Scalable Vector Graphics"

Меню "Файл" - "Экспорт в:" - "Масштабируемая Векторная Графика"

Векторная графика - это способ представления изображений в виде набора графических элементов, выраженных геометрическими фигурами - линиями (прямые, плавные кривые, ломаные полигоны), прямоугольниками, кругами, замкнутыми полигонами и т.п. Такие элементарные фигуры описываются координатами их точек, а не их действительным изображением, поэтому файлы векторных рисунков могут быть очень компактными. Но главным преимуществом векторной графики - это возможность изменять масштаб её изображения без потери качества. Эта особенность особенно привлекательна для изображения генеалогических деревьев, где изменение масштаба в широких пределах является одним из главных приемов навигации по дереву.

"Scalable Vector Graphics (SVG, "Масштабируемая Векторная Графика")" - это стандарт Консорциума WWW, определяющий описание векторных изображений в формате XML. Файлы с такими изображениями могут показываться в веб-браузерах как с помощью встроенных функций (в браузере Mozilla Firefox), так и посредством специальных plug-in'ов (например, Adobe SVG Viewer в Internet Explorer). Надо сказать, что поддержка SVG различными браузерами реализована в различной степени и в целом пока оставляет желать лучшего, хотя и заметно улучшается от версии к версии. Так, Internet Explorer до сих пор (до версии 7) не имеет встроенной поддержки SVG, поэтому пользователям приходится устанавливать plug-in, чтобы посмотреть векторное изображение.

Программа "Родственники" может генерировать SVG файлы как встроенные в интерактивную гипертекстовую (HTML) страницу, так и отдельные SVG файлы. Такую страницу можно просматривать в браузере. Интерактивность её заключается в том, что рамки тех родственников, которые имеют комментарий или ссылки, реагируют на щелчки мышью показом сведений об этих родственниках. Отдельные SVG файлы такой интерактивностью не обладают и предназначены в основном или для импорта в векторные графические редакторы (Adobe Illustrator, CorelDRAW) или для передачи в бюро печати для распечатывания дерева на широкоформатных плоттерах.

Элементы диалогового окна "Экспорт в Масштабируемую Векторную Графику":

  1. Переключатели "Экспортировать Все/Выделенное" позволяет выбрать: все дерево или только его выделенная часть будет экспортирована.
  2. Переключатели "Создать SVG в HTML/Только SVG" позволяет создать либо html-страницу и интерактивный svg-файл, который будет в ней показываться, либо только отдельный неинтерактивный svg-файл для печати и импорта.
  3. Группа переключателей "Фон" позволяет задать фон рисунка:
    Обычный - тот, который используется в самой программе;
    Белый - соответственно, белый.
  4. Переключатель "Добавить персональные сведения" указывает, делать ли HTML страницу интерактивной. Если переключатель включен, то в поддиректории [имя_html_страницы]_files будут созданы файлы, содержащие сведения о родственниках. Эти сведения будут показываться в отдельном окне браузера при нажатии мышкой на рамку соответствующего родственника.
  5. Выпадающий список "Кодировка" позволяет задать кодировку таких файлов с персональными сведениями. О кодировке см. также здесь.
  6. Переключатель "Сжатый (.svgz)" создает сжатый svg-файл с расширением .svgz.
    Примечание: Сжатый svgz-файл, встроенный в html-страницу не будет работать в браузере Mozilla Firefox.
  7. После нажатия на кнопку "Экспорт" появится диалоговое окно для ввода имени файла. Если создается "SVG в HTML", то необходимо указать имя html-файла (по умолчанию предлагается создать файл с именем имя_файла_дерева.html). Кроме этого, в этой же директории будет создан файл имя_html_файла.svg (или .svgz) и, если отмечен флаг "Добавить персональные сведения", директория имя_html_файла_files с информационными файлами для родственников и семей (только тех, кто имеет комментарии и/или ссылки).
    В случае, если создается "Только SVG", то будет создан единственный svg (или svgz) файл с заданным именем.

Навигация по SVG-дереву

SVG-файл, показываемый в html-странице, содержит встроенный JavaScript, обеспечивающий навигацию по дереву и показ информационных файлов родственников.

Первоначально, при открытии страницы, дерево показывается так, чтобы оно полностью помещалось в окне браузера. Масштаб изображения при этом может быть очень мелким, если дерево большое.

    Четыре кнопки в левом верхнем углу окна предназначены для изменения масштаба:
  1. Кнопка [image] - устанавливает масштаб 1:1;
  2. Кнопка [image] - устанавливает такой масштаб, чтобы дерево полностью помещалось в окне браузера (как при открытии страницы);
  3. Кнопка [image] - увеличивает масштаб примерно на 40%;
  4. Кнопка [image] - уменьшает масштаб примерно на 40%.

Центр изменения масштаба при использовании этих кнопок - всегда центр окна браузера.

Если держать нажатой клавишу Ctrl и щелкнуть по дереву в место свободное от рамок родственников, то масштаб увеличится примерно на 40%.

Также, если держать нажатой клавиши Ctrl и Shift и щелкнуть по дереву в место свободное от рамок родственников, то масштаб уменьшится примерно на 40%.

Центр изменения масштаба при использовании мыши - всегда место щелчка.

Дерево можно целиком перемещать в любом направлении, "ухватив" его мышкой в любом месте, свободном от рамок родственников.

Щелчок мыши на рамке родственика, над которой курсор мыши превратился в "лапку", откроет отдельное окно браузера со сведениями об этом родственнике (если он имеет комментарии и/или ссылки).

Примечание: Не рекомендуются для показа в виде SVG-графики очень большие деревья (больше 1000 персон), т.к. в силу врожденных особенностей данной технологии рисунки с большим количеством элементом перерисовываются довольно медленно. Это выражается в замедленной реакции на перемещения/изменения масштаба - иногда на несколько секунд! Adobe SVG Viewer plug-in в этом отношении несколько быстрее, чем другие, особенно встроенный SVG-показ в Mozilla Firefox.

См. также:
Страница загрузки Adobe SVG Viewer'а на сайте Adobe.
Справочный интернет-ресурс по векторной графике.
Страница веб-сайта Консорциума WWW, посвященная формату SVG.


Диалоговое окно "Конфигурация"

Меню "Файл" - "Конфигурация..."

Вызывает диалоговое окно для изменения конфигурации программы и редактирования файла конфигурации Relatives.ini, который находится в директории программы.

Диалоговое окно "Конфигурация" позволяет задать пять параметров конфигурации:

1) Язык интерфейса программы (параметр lang в файле Relatives.ini). Заданный параметр имеет преимущество при установке программой языка интерфейса. См. Многоязычный интерфейс.

2) Максимальное число отмен изменений (параметр undo_lev в файле Relatives.ini). Этот параметр может быть от 4 до 32. См. Меню "Правка" - "Отменить"

3) Цвет фона дерева по умолчанию в шестнадцатеричном формате (параметр bgcolor в файле Relatives.ini).
Примечание: Изменение фона дерева в окне конфигурации не изменяет цвет фона, заданный в заголовке (тэг _BG) уже открытого файла, он просто установит цвет фона программы по умолчанию, т.е. все последующие файлы будут иметь этот цвет фона, если в заголовке файла не указан иной цвет. Для изменения цвета фона в заголовке файла измените значение его элемента "Фоновый цвет".

4) Автоматическая установка даты и времени изменения записи (тэг CHAN) при её редактировании - параметр chan_stamp в файле Relatives.ini, который может принимать значения 0, 1 или 2.
chan_stamp=0 или отсутствует - дата и время изменения записи не устанавливаются;
chan_stamp=1 - устанавливается только дата изменения;
chan_stamp=2 - устанавливается и дата и время изменения.

5) Флаг "Автозагрузка последнего открытого файла" (параметр open_last в файле Relatives.ini).

Пример файла конфигурации Relatives.ini:
lang=en
bgcolor=DDEEDD
undo_lev=16
chan_stamp=1
open_last=yes

Если какой-либо параметр не задан, то будет применяться его значение по умолчанию:
1) Язык программы - язык операционной системы Windows данного компьютера;
2) Цвет фона дерева - D2ECD2 (светло-фисташковый, как цвет фона этого текста);
3) Максимальное число отмен изменений - 8;
4) Автоматическая установка даты и времени изменения записи - нет;
5) Автозагрузка последнего открытого файла - нет.


Меню "Правка"

Меню "Правка" содержит обычные для этого меню пункты отмены последнего действия, копирования/вставки, открытия Редактора, поиска и т.п.


Меню "Правка" - "Отменить" и "Вернуть"

Отменяет/возвращает последнее изменение дерева - перемещение рамок родственников, удаление, вставка, вырезание, изменение записи в Редакторе и т.п. В данной версии программы можно отменить/вернуть до 32 последних изменений (задается в файле конфигурации (см. "Кофигурация").


Меню "Правка" - "Снять выделение"

Отменяет выделение родственников в дереве. "Горячие клавиши" для этой команды: Ctrl + Пробел, но можно также просто Пробел. Выделение также снимается, если дважды щёлкнуть мышью на свободное от рамок родственников место или однократно щелкнуть на каком-нибудь НЕвыделенном родственнике.


Меню "Правка" - "Вырезать"

Копирует в буфер обмена выделенных родственников и удаляет их из дерева.

См. также: Как копировать - вырезать - вставлять


Меню "Правка" - "Копировать"

Копирует в буфер обмена выделенных родственников.

См. также: Как копировать - вырезать - вставлять


Меню "Правка" - "Удалить"

Удаляет выделенный родственников из дерева, предварительно запросив подтверждение.

См. также: Как копировать - вырезать - вставлять


Меню "Правка" - "Поиск"

Окно "Поиск" предлагает простой поиск родственников или семей по основным элементам: для родственников - это имя-отчество, фамилия, дата рождения, дата смерти, комментарии, ссылки, а также по всем элементам сразу; для семьи - комментарии, ссылки или по всем элемента сразу.

Можно задать до трех ключевых слов поиска.

Поиск производится в границах слова. Это означает, что заданное ключевое слово будет искаться внутри каждого слова элемента, т.е. фразы (несколько слов с пробелами между ними) не ищутся.

В ключевых словах можно использовать простые знаки подстановки, подобные тем, которые применяются при поиске в DOS и Windows. Эти знаки следующие:
* (звездочка) - обозначает любое количество (включая ноль) любых знаков;
? (вопрос. знак) - обозначает один любой символ;
+ (плюс) - обозначает один и более любых символов.

Если ключевое слово на задано вообще (поле "Искать:" оставлено пустым), то это эквивалентно заданию поиска "*", т.е. поиску любого непустого значения указанного элемента.

Поиск проводится без учета больших и малых букв (без учета регистра). Русские буквы 'е' и 'ё' не различаются.

Примеры:

  • Поисковое слово - "Петр". Будут найдены только имена, точно соответствующие слову "Петр" или "Пётр".
  • Поисковое слово - "Петр*". Будут найдены имена, начинающиеся с этого слова: "Петр", "Пётр", "Петрович", "Петров", "Петрушенко" и т.п.
  • Поисковое слово - "Петр+". Будут найдены имена, начинающиеся с этого слова: "Петрович", "Петров", "Петрушенко" и т.п., но не "Петр" или "Пётр", т.к. знак '+' указывает, что на его месте должен быть хотя бы один символ.
  • Поисковое слово - "Петр??". Будут найдены имена, соответствующие словам "Петров", "Петрис" и т.п., но не "Петр", "Петрович" или "Петрушенко" т.к. 2 знака '?' указывают, что на их месте обязательно должны быть два любых символа.
  • Поисковое слово - "*москв*". Будут найдены элементы, содержащие, например, такие фразы: "Проживает в Москве.", или "Уехал из Москвы в 30-х годах.", или "Имел дом в Замоскворечье." и т.п., т.к. знак '*' означает, что на его месте может быть любое количество любых символов, или вообще не быть никаких символов.

Переключатели И-ИЛИ работают при поиске более одного ключевого слова и задают логику поиска: "И" означает "найти записи, содержащие все заданные ключевые слова", а "ИЛИ" означает "найти записи, содержащие любое из заданных ключевых слов".

Переключатель "Только в выделенном" работает только при поиске родственников и позволяет искать только среди выделенных родственников.

Переключатель "Всегда сверху": если он включен, то окно поиска будет всегда оставаться поверх других окон.

Результат поиска показывается в Списках родственников или семей. Если ничего не найдено, показывается соответствующий пустой список.

См. также:
Быстрый поиск


Меню "Правка" - "Заголовок файла"

Вызывает на редактирование заголовок файла.

См.: Редактирование заголовка файла


Меню "Правка" - "Новая семья из выделенных"

Вызывает Редактор для создания новой семьи с возможностью выбора её членов только из выделенных родственников. Соответственно, предварительно необходимо выделить нужных родственников.

См. также:
Как создать новую семью
Как выделять родственников и семьи


Меню "Правка" - "Пользовательские тэги"

Меню "Правка" - "Пользовательские тэги" открывает Редактор пользовательских тэгов.

ВНИМАНИЕ! Создание/Редактирование пользовательских тэгов требует от пользователя знания основ формата GEDCOM и определенной компьютерной подготовки.

Пользовательские тэги (тэги, определяемые пользователем) - это типы элементов, не описанные в стандарте GEDCOM, а создаваемые пользователем для своих нужд. Обычно такие тэги создаются производителями генеалогических программ, так что термин "пользовательский", то есть относящийся к конечному пользователю, не совсем верен. Пользовательские тэги применяются для описания элементов, которых, по мнению их создателей, не хватает в стандартном наборе GEDCOM тэгов или если такие элементы необходимы для нормального функционирования программы. Так, в программе "Родственники" в запись типа Родственник (тэг INDI) добавлены пользовательские тэги _X и _Y, хранящие информацию о геометрических координатах родственников в дереве. Без этих тэгов программа не смогла бы работать - в стандарте GEDCOM не предусмотрено никаких методов сохранения подобных данных. Механизм определения пользовательских тэгов был введен создателями формата GEDCOM в версии 5.3 с помощью специального тэга SCHEMA, но не был хорошо продуман и не позволял в достаточной мере описать дополнительные тэги как новые типы данных. Поэтому уже в версии 5.5 авторы GEDCOM отказались от тэга SCHEMA, и вопрос, как говорится, "повис в воздухе" - пользовательские тэги по-прежнему можно было вводить, но описывать их уже было нечем...

Программа "Родственники" предлагает свой механизм поддержки пользовательских тэгов, предусматривающий более полное их описание - в частности, для тэга можно описать тип его значения - строка, текст, ссылка на запись и т.д.

При импорте GEDCOM файла, созданного другой программой, механизм поддержки пользовательских тэгов работает следующим образом:

  1. Если в заголовке файла присутствует тэг SCHEMA, то описания пользовательских тэгов прочитываются из него и сохраняются в программе;
  2. Все пользовательские тэги (т.е. те, имена которых начинаются со знака подчеркивания "_"), не описанные в SCHEMA, также сохраняются в программе;
  3. Все стандартные GEDCOM-тэги, обнаруженные не на своих стандартных местах, помечаются как пользовательские и сохраняются в программе;
  4. Тэги, которые не найдены среди стандартных GECDOM-тэгов и не начинаются с "_", также помечаются как пользовательские и сохраняются в программе, а к их именам спереди прибавляется символ "_".
  5. Все прочитанные таким образом тэги можно затем редактировать в Редакторе пользовательских тэгов.
  6. Тэг SCHEMA в заголовке файла невидим (и не может быть добавлен) - все функции по обслуживанию пользовательских тэгов доступны через Редактор пользовательских тэгов.
  7. При экспорте в GEDCOM формат информация о пользовательских тэгах сохраняется в заголовке файла в элементе SCHEMA.

Редактор пользовательских тэгов

При открытии Редактора на левой панели будет список пользовательских тэгов данного файла. Каждый тэг представлен "цепочкой" тэгов в виде Тэг - тэг - ... - тэг, то есть тэги показываются в виде "Главный тэг (Родственник, Семья и т.п.) - затем принадлежащий ему тэг - и т.д... - наконец, собственно пользовательский тэг".

При выборе строки в списке на правой панели отображаются свойства выбранного пользовательского тэга:

  1. Тэг - имя тэга;
  2. Определение - краткое определение, метка - то, как тэг будет представлен, например, в дереве элементов записи и т.п.;
  3. Описание - развернутое описание тэга, что означает данный тэг, какие данные он хранит;
  4. Помощь - еще более развернутое описание тэга, включающее в себя информацию о том, как редактировать значение данного тэга, какие значения он может принимать, и т.п. Эта информация появляется при вызове помощи в окне редактирования элемента. См.: Редактор;
  5. Мин. количество - какое минимальное количество элементов с данным тэгом может иметь элемент-родитель. Может быть 0 или 1;
  6. Макс. количество - какое максимальное количество элементов с данным тэгом может присутствовать в элементе-родителе. Может быть от 1 до 65535;
  7. Тип значения - тип значения, которое может принимать данный элемент. Эти типы: пусто, строка, текст, шаблон, ссылка, выбор;
  8. Длина значения - максимальная длина значения для типов "строка" и "шаблон".

Кнопки "Новый" и "Правка" на нижней панели открывают окно редактора тэга для создания нового или редактирования выбранного пользовательского тэга.

Кнопка "Удалить" удаляет выделенный пользовательский тэг.

Обратите внимание, что удаление тэга означает, что все элементы с данным тэгом тоже должны быть удалены. Поэтому перед удалением программа проверяет, есть ли в файле такие элементы и, если они найдены, выдает предупреждение. Пользователь может отменить удаление и просмотреть записи, в которых найдены эти элементы (см. кнопка "Проверить").

Если удаляемый тэг имеет подтэги (тоже, естественно, пользовательские), то эти подтэги также будут удалены (вместе с соответствующими элементами).

Как видите, удаление пользовательского тэга (а также изменение типа его значения) может привести к потере данных, поэтому надо быть внимательным и действовать осторожно. Тем более, что в данной версии программы изменения в пользовательских тэгах не могут быть отменены.

Кнопка "Проверить" выдает список записей, в которых есть элемент с данным пользовательским тэгом. Применяется для проверки перед удалением тэга (см. кнопка "Удалить").

Редактор тэга

Имеет следующие элементы интерфейса:

  1. Тэг - текстовое поле для задания имени тэга.
    Имя тэга должно начинаться со знака подчеркивания '_' и состоять из больших букв английского алфавита от A до Z, цифр 0-9 и '_'. Никакие другие символы редактор ввести не позволит. Внимание: если вы не можете ничего ввести в это поле, то это, скорее всего потому, что раскладка вашей клавиатуры переключена на национальную, неанглийскую раскладку! Если Вы забыли начать имя тэга со знака '_', редактор исправит это.
  2. Контекст - позволяет определить "родительский" тэг для нового тэга, т.е. тэг, в котором пользовательский тэг будет "подтэгом". В данной версии программы задать контекст можно только для нового пользовательского тэга, т.е. при его создании.

    Контекст задается следующим образом:
    а) Выберите из выпадающего списка тэг самого верхнего уровня (Родственник, Семья и т.д.) и нажмите кнопку "Добавить" - тэг появится в текстовом поле выше, а выпадающий список будет теперь содержать все возможные подтэги выбранного тэга.
    б) Выберите из выпадающего списка тэг следующего уровня и нажмите кнопку "Добавить" - выбранный тэг добавится к тэгу верхнего уровня. Подобным образом можно задать "цепочку" родительских тэгов нашего пользовательского тэга.
    в) Кнопка "Убрать" позволяет удалить последний из тэгов контекста.
  3. Определение - поле ввода определения, или метки тэга. Метка тэга должна быть о возможности короче, желательно одним словом. Под этой меткой тэг будет показываться в программе, как например тэг INDI имеет метку "Родственник".
  4. Описание - поле ввода описания. Описание определяет тэг более подробно и не имеет ограничения на длину. Тем не менее, не делайте описание слишком длинным, желательно не более 50-60 знаков.
  5. Помощь - текстовое поле для ввода текста помощи. Длина этого текста не ограничена, и он может быть многострочным. Помощь будет доступна пользователю во время создания/редактирования элемента с данным тэгом и потому может содержать расширенное описание тэга, информацию о том, какие значения может принимать данный элемент, какие-то другие особенности.
  6. Мин. количество - выпадающий список со значениями 0 и 1; 0 означает, что элемент с таким тэгом не обязателен, 1 - что он обязательно должен присутствовать в родительском элементе хотя бы один раз.
  7. Макс. количество - поле для задания максимального количества элементов с данным тэгом в родительском элементе. Может принимать значение от 1 до 65535.
  8. Тип значения - набор радиокнопок для задания типа значения данного тэга.
    1. Пусто - элемент данного тэга не имеет значения. Такой элемент просто содержит другие элементы.
    2. Строка - значение - одна строка текста. Макс. длину строки (до 248 символов согласно стандарта GEDCOM) можно указать в последнем текстовом поле, но реально в данной программе она не ограничена.
    3. Текст - значение - многострочный текст неограниченной длины.
    4. Шаблон - то же, что и строка, но значение должно соответствовать определенному шаблону. Шаблон задается в текстовом поле рядом с помощью регулярного выражения. Например, чтобы ограничить значение четырехзначным десятичным числом, используется регулярное выражение "\d{1,4}". О регулярных выражениях читайте: Mastering Regular Expressions, 2nd Edition, Jeffrey E. F. Friedl, O'Reilly and Associates, 2002.
    5. Ссылка - значение элемента данного тэга - ссылка на запись. Тип записи выбирается из выпадающего списка рядом.
    6. Выбор - значение элемента данного тэга может принимать одно из нескольких заранее заданных значений. Список этих значений задается в текстовом поле ниже. Каждая строка текста в этом списке задает одно значение. Значение может быть снабжено комментарием, записанным после знака равенства '='. Например, список
      CAD = Канадский доллар
      USD = Доллар США
      FR = Французский франк
      задает три возможных значения - CAD, USD и FR. Комментарии после знака равенства будут показываться во время редактирования элемента, однако будут проигнорированы Редактором записей (только левая часть строки, до знака равенства, будет рассматриваться Редактором, как значение).
  9. Длина значения - для задания максимальной длины значения данного тэга.
  10. Кнопки "OK" и "Отмена" - понятно для чего.

См. также:
О "расширенной" поддержке пользовательских тэгов
Меню "Файл" - "Импорт из:" - "GEDCOM 5.5 файл"

Примечание:
Тэги в программе "Родственники" почти нигде не представлены своими настоящими именами (INDI, FAM, SOUR и т.п.), а только своими краткими определениями (Родственник, Семья, Источник и т.п.)

Примечание:
Изменение типа значения уже существующего пользовательского тэга также может привести к потере данных, если элементы данного тэга уже присутствуют в записях дерева. Например, если тип данных был "Ссылка", а вы сменили его на "Строка", то ссылка на запись неизбежно потеряется. Или при замене типа "Текст" на "Строка" из данных будут удалены все переводы строки, чтобы сделать текст однострочным. Программа проверяет, какие данные могут быть потеряны или изменены и предупреждает об этом. Тем не менее, будьте внимательны при смене типа значения пользовательского тэга!


Меню "Вид"

Меню "Вид" содержит 2 группы пунктов:

1) пункты относящиеся к представлению генеалогического дерева на экране: масштабирование, выравнивание и распределение рамок родственников, перестановка рамок и вызов "увеличительного стекла";

2) пункты показа "списков": список родственников, список семей, список записей общего пользования и информационного окна заголовка файла.


Меню "Вид" - "Предыдущий" и "Следующий".

Эти пункты меню работают подобно "Правка" - "Отменить/Вернуть", но только не с изменением дерева, а его видом: масштабом и положением на экране. Причем, за одно изменение вида считается:

- при перемещении дерева перетаскиванием мышкой: от момента нажатия кноки мыши до момента её отпускания;

- при изменении масштаба пунктами меню "Вид" ("Всё дерево", "Масштаб 1:1", "Увеличить", "Уменьшить": каждое применение команда меню;

- при изменении масштаба колёсиком мыши: от начала вращения колёсика до остановки на более, чем 1 секунду.

Программа запоминает до 64 изменений вида.


Пункты меню "Вид" для изменения масштаба

Пункт "Все дерево" - устанавливает масштаб таким, чтобы все дерево поместилось в окне. Учтите, что если дерево очень большое (порядка нескольких тысяч человек), то все дерево будет иметь вид неровной черной полоски вдоль верхнего края окна - особенно часто это встречается при импорте больших GEDCOM файлов.

Пункт "Масштаб 1:1" - устанавливает масштаб 1:1.

Пункт "Увеличить" - увеличивает масштаб примерно в 1.4 раза.

Пункт "Уменьшить" - уменьшает масштаб примерно в 1.4 раза.

Примечание: Если масштаб мелкий, то текст внутри рамок родственников показываться не будет, т.к. мелкий шрифт (меньше 4 пунктов) все равно неразличим.

При мелком масштабе изображения можно воспользоваться помощью "лупы" - специального плавающего окна, в котором часть дерева показывается в масштабе 1:1.


Меню "Вид" - "Лупа"

Вызывает специальное окно, в котором та часть дерева, которая находится в данный момент под указателем мышки, показывается в масштабе 1:1.

Окно Лупа не имеет обычной рамки и заголовка, однако его, также как и обычное окно, можно перетаскивать мышкой в любое место и изменять его размеры.

В центре окошко имеет что-то наподобие "прицела" - крестик, который указывает точное положение указателя мыши. С помощью этого "прицела" можно попасть мышкой в нужную рамку, что обычно затруднительно при мелком масштабе.


Меню "Вид" - "Выровнять"

Меню "Вид" - "Выровнять" доступно, когда выделено более одного родственника и содержит два подпункта:

по горизонтали - выбранные рамки выравниваются по горизонтали, как показано на рисунках:

До выравнивания:

После выравнивания по третьей слева рамке:

После выделения родственников необходимо указать программе, по какой рамке Вы желаете сделать выравнивание - для этого щелкните по этой рамке. Если Вы не сделали этого, программа об этом напомнит.

по вертикали - выравнивание происходит так, чтобы центры рамок расположились на вертикальной линии:

До выравнивания: | После выравнивания по нижней рамке:

Как и в предыдущем случае, после выделения также надо указать программе, по какой рамке Вы желаете сделать выравнивание.


Меню "Вид" - "Распределить"

Меню "Вид" - "Распределить" доступно, когда выделено более двух родственников и содержит два подпункта:

на равные расстояния между рамками - рамки распределяются по горизонтали так, чтобы расстояния между их краями стали одинаковы.

на равные расстояния между центрами рамок - рамки распределяются по горизонтали так, чтобы расстояния между их центрами стали одинаковы.

Крайние правая и левая рамки при этом не меняют положения. На рисунках показано, как выровнять и распределить группу хаотично расположенных рамок:

До выравнивания и распределения:

После выравнивания по горизонтали и распределения на равные расстояния между рамками:

То же, только после выравнивания по горизонтали и распределения на равные расстояния между центрами рамок:


Меню "Вид" - "Поменять местами"

Меню "Вид" - "Поменять местами" доступно, когда выделено более одного родственника.

Меняет положение выделенных рамок "зеркально" относительно вертикальной оси. Полезный инструмент при ручном "распутывании" дерева после импорта из GEDCOM файла. Пара примеров:

1) После импорта GEDCOM файла часто встречается такое расположение супругов:

После выделения этой пары и перемены мест этот кусочек дерева смотрится немного лучше:

2) Оба мужа Сюзанны Шильд расположились по одну сторону от неё:

Выделите её с ближним из супругов и поменяйте местами - теперь понятно, от кого идут линии к их потомству. Заодно можно поменять местами и соседнюю пару:

Клавиши быстрого доступа к этому пункту меню - Ctrl+W. Функция "Поменять местами" интересна еще и тем, что при повторном применении к тем же выделенным рамкам возвращает все на свои места.


Меню "Вид" - "Список родственников"

Меню "Вид" - "Список родственников" показывает список всех родственников дерева.

См. также: Список родственников


Меню "Вид" - "Список семей"

Меню "Вид" - "Список семей" показывает список всех семей дерева.

См. также: Список семей


Меню "Вид" - "Заголовок файла"

Меню "Вид" - "Заголовок файла" показывает сведения о Заголовке файла в Информационном окне.

См также: Информационное окно


Меню "Вид" - "Общие записи"

Меню "Вид" - "Общие записи" показывает список всех записей общего пользования данного файла.

См. также: Список записей общего пользования


Меню "Сервис"

В меню "Сервис" находятся некоторые инструменты для работы с генеалогическими деревьями.


Медиа Мастер

Родственники и семьи могут иметь ссылки на так называемые медиа-файлы - документы, фотографии, рисунки, страницы в Интернете, файлы других деревьев и т.п. При составлении дерева пользователь подчас создает множество ссылок на файлы, хранящиеся в разных директориях компьютера, так что бывает трудно запомнить, где что находится. Кроме того, ссылки могут указывать не только на файлы, хранящиеся в папке, где находится сам файл дерева или в Директории документов, но и быть абсолютными (т.е. иметь вид C:\Works\Archive\Photos\Petrov.jpg) или храниться в системных папках документов - "Мои документы", "Мои рисунки", "Мои видеозаписи" или "Моя музыка". Когда потребуется собрать все медиа-файлы вместе, такие файлы могут легко выпасть из поля зрения. Файлы, на которые указывают ссылки, могут быть также переименованы, удалены или перемещены в другое место, но ссылки по-прежнему будут указывать на эти уже несуществующие файлы. В этом случае, когда нужно будет перенести дерево и все относящиеся к нему файлы на другой компьютер, записать на DVD, разместить на веб-сервере или послать по электронной почте, часть файлов могут просто потеряться. Для управления ссылками в программе "Родственники" существует специальный инструмент, Медиа Мастер. Он позволяет получить список всех ссылок дерева, увидеть, какие из них действительны, а какие нет, куда они реально указывают и сколько всего их файлы занимают места на диске. В Медиа Мастере можно исправить потерянные ссылки или удалить их, а также подготовить дерево к переносу, записав его со всеми его медиа-файлами в отдельную директорию или ZIP-архив. При этом в такую директорию "сборки" (или ZIP архив) будут скопированы все доступные на данном компьютере медиа-файлы, относящиеся к данному дереву, а ссылки в дереве-копии будут "перенаправлены" на них. В результате будет получен полностью автономный комплект файлов, который может быть перенесен на другой компьютер без каких-либо потерь медиа-файлов.

Элементы интерфейса и порядок работы

В главном окне Медиа Мастера слева находится список всех файлов, на которые есть ссылки в данном дереве.
Файлы в списке могут быть "подсвечены" разными цветом в зависимости от состояния файла:

Белый цвет указывает, что ссылка действительна, а её файл найден в директории файла дерева или в одной из Директорий документов. Это, так сказать, "идеальный случай". Такие файлы не требуют дальнейшего внимания, тем не менее можно редактировать такие ссылки или вовсе удалять их.

Внимание! Манипуляции, которые вы проводите с ссылками в главном окне Медиа Мастера (редактирование и удаление ссылок соответствующими кнопками) приведут к реальным изменениям ссылок в самом дереве. Однако последующий этап "собирания" файлов в одну директорию никак не отразится ни на ссылках дерева, ни на самих файлах - они будут просто скопированы (а не перемещены), а ссылки будут "перенаправлены" только в файле дерева-копии, записанном в директорию "сборки".
Это, кстати, предоставляет возможность использовать Медиа Мастер как удобный инструмент для контроля над ссылками, их коррекции и т.п.

Голубой цвет обозначает файлы, которые расположены в Интернете. Эти ссылки также не требуют каких-либо мер для подготовки к переносу, т.к. будут доступны с любого другого компьютера, если он подключен к Интернету. Учтите, что файлы, на которые указываю такие ссылки, не копируются в директорию "сборки", а ссылки в дереве-копии оставляются такими, какие есть в оригинале.

Жёлтый цвет свидетельствует, что файл ссылки имеет абсолютный адрес, или найден в одной из системных папок документов ("Мои документы" и т.п.) или одной из Директорий документов, если эта директория сама имеет абсолютный адрес. Такие файлы также не требуют особых мер, если только вы не желаете упорядочить свои медиа-файлы и перенести их поближе к файлу дерева. При "сборке" такие файлы будут скопированы в директорию "сборки", а ссылки в дереве-копии "перенаправлены" на них.

И, наконец, красный цвет указывает, что с ссылкой имеются проблемы - её файл нигде не найден - ни в директории дерева, ни в Директориях документов, ни в системных папках документов. Такую ссылку следует или исправить, назначив ей существующий файл, или удалить... хотя можно и оставить как есть - просто она не будет работать и после переноса дерева на другой компьютер.

Кнопка "Редактировать ссылку" открывает диалоговое окно, в котором можно изменить путь к файлу ссылки. Изменение другие элементов ссылки (Имя ссылки и Комментарии) в Медиа Мастере не предусмотрено, это можно сделать в Редакторе записей.

Кнопка "Удалить ссылку" позволяет удалить выбранную ссылку.

Внимание! Окно Медиа Мастера, в отличие от обычных диалоговых окон, не блокирует доступ к главному окну программы. Это позволяет при необходимости перейти в главное окно, сделать необходимые изменения, и вернуться назад в Медиа Мастер. Не забывайте после этого обновлять список ссылок кнопкой "Обновить список"!

При выборе файла в списке слева на панели справа показывается информация об этой ссылке, а двойной щелчок открывает документ ссылки.

В поле "Запись:" - тип записи (Родственник, Семья или запись общего пользования), которой принадлежит данная ссылка. Если ссылка принадлежит элементу записи, то тип записи будет показан в виде цепочки "Запись - элемент - ... - элемент"

"Где найден:" - показывает путь, по которому найден файл ссылки. Путь может быть или абсолютным, или начинаться с Директории документов, или адресом Интернета, а также "Не найден".

"Имя ссылки:" и "Комментарии к ссылке:" - соответственно, имя и комментарии. А также "Формат:" - расширение файла ссылки, если оно известно программе.

После того, как ссылки приведены в порядок, можно приступать к "сборке" файлов.

Поле "Общий размер медиа-файлов" показывает два числа: первое - это общий размер всех файлов списка (за исключением не найденных), и второе - также общий размер, включая содержимое тех директорий, которые являются объектом ссылок, указывающих на директории (а не на отдельные файлы). Эта информация позволяет оценить размер предстоящей "сборки". Учтите, что в него не входит размер самого файла дерева, а только локальные медиа-файлы. Размер удаленных файлов (находящихся в Интернете), разумеется, тоже не учитывается, т.к. они все равно не будут включены в "сборку".

Кнопка "Подготовить файлы для переноса" открывает диалоговое окно:

диалоговое окно сборки

Верхний выпадающий список позволяет задать папку, в которую будут скопированы те файлы, которые имеют абсолютные пути или находятся в системных медиа-директориях ("Мои документы" и т.п.). Список содержит локальные (но не абсолютные!) Директории документов, а также директорию самого дерева. Можно также имя новой папки. Все эти директории будут созданы в папке "сборки" по необходимости, т.е. если найдутся файлы, которые надо будет туда записывать.

Название флага "Если медиа-файл является папкой, сохранять всё её содержимое" говорит само за себя. Проверьте, что такие папки содержат только нужные файлы...

И, наконец, переключатель ниже позволяет задать, в каком виде будет сохранено само дерево - как файл программы "Родственники" (.rel) или как GEDCOM файл (.ged).

При нажатии на кнопку "Сохранить в директории" будет предложено выбрать папку. Папка должна быть пустая (её можно создать прямо в диалоговом окне выбора директории), иначе программа предложит создать в выбранной папке новую поддиректорию с именем имя_файла_trans.

См. также:
Создание и редактирование ссылок
Редактирование заголовка дерева


Меню "Сервис" - "Создать файлы Web-приложения"

Создать файлы Web-приложения

Этом диалоговое окно предназначено для создания набора файлов, необходимых для публикации ваших генеалогических деревьев в Интернете с помощью интерактивного Web-приложения, использующего последнюю версию языка разметки HTML5. Эти файлы загружаются на сервер так называемого "хостинга сайтов", например, на бесплатный narod.ru, и после этого деревья становятся доступными в Интернете примерно в таком же виде, в каком вы видите их в программе "Родственники". Пример таких деревьев, опубликованных в Интернете находится по адресу http://andreidouglas.com/RelView.html. Если необходимо обеспечить тайну частных сведений, находящихся в публикуемых деревьях, то файлы можно зашифровать - тогда доступ к ним будут иметь только лица, которым вы доверили пароль доступа.

Элементы интерфейса и порядок работы

Для подготовки деревьев к публикации в Интернете следует определить, какие файлы надо будет загрузить на сервер. В первую очередь это, конечно, файлы самих деревьев, а также медиа файлы, на которые в публикуемых деревьев есть локальные ссылки. ["локальные ссылки" - это ссылки на файлы, расположенные не где-то в доступном Интернете, а на вашем компьютере, "местные"] Лучше всего сделать это с помощью Медиа Мастера (Меню "Сервис").

Пример: вы собираетесь опубликовать в Интернете 2 дерева: Ивановых (Файл Ivanov.rel) и Петровых (файл Petrov.relx - зашифрованный с помощью диалога "Зашифровать/Расшифровать"). Хотя буквы русского алфавита и допустимы в именах публикуемых файлов, рекомендуется всё же использовать только латиницу, чтобы избежать досадных неожиданностей. Это же касается, кстати, и имён любых других файлов, загружаемых на сервер хостинга. Рекомендуемый порядок создания файлов Web-приложения таков:

1) Откройте диалоговое окно Создать файлы Web-приложения;
2) Введите имя папки, общей для всех файлов деревьев в поле "Общая папка с деревьями" (например, trees). Общей для всех деревьев папки может не быть - тогда оставьте это поле пустым;
3) Последовательно добавьте в таблицу "Названия и файлы деревьев" имена деревьев под которыми они будут показываться в приложении (например: "Костромские Петровы") и имена файлов деревьев (Ivanov.rel и Petrov.relx). Если на сервере файлы необходимо будет расположить в разных поддиректориях в папке trees, то добавьте перед именами файлов эти поддиректории: ivanov/Ivanov.rel и petrov/Petrov.relx;
4) Порядок следования файлов в таблице можно менять кнопками Вверх, Вниз, а редактировать и удалять - кнопками Правка и Удалить;
5) Сохраните файлы Web-приложения (меню Файл - Сохранить/Сохранить как...), указав имя файла (например, MyTrees.html);

В результате в указанной вами папке будут созданы:
1. файл главной страницы приложений MyTrees.html,
2. папка relview_files с необходимыми для работы приложения файлами (скрипты, языковые файлы).

Предупреждение: если в указанной вами папке уже была папка с именем relview_files, то она НЕ БУДЕТ переписана или изменена каким либо образом.

Следующим шагом будет загрузить созданные файлы приложения на сервер и создать там необходимую структуру директорий. В нашем примере, в одной директории на сервере должны находиться файл MyTrees.html и папка relview_files, а также папка trees с подпапками ivanov и petrov, в которые вы поместите, соответственно, файлы Ivanov.rel и Petrov.relx и все необходимые им медиа-файлы с их папками.

Web-приложение может работать как на компьютерах с большим экраном (настольные и ноутбуки), так и мобильных устройствах с сенсорным экраном (планшеты и смартфоны). Для версии приложения, которое работает на мобильных устройствах в адресе главной страницы приложения надо указать параметр, содержащий букву M (латинскую) в любом регистре. Например, в нашем примере адрес может выглядеть так:
http://ivanov.narod.ru/MyTrees.html?M
или
http://ivanov.narod.ru/MyTrees.html?mobile
то есть если часть адреса после вопросительного знака содержит латинскую букву m в любом регистре, то будет показана версия приложения для мобильных устройств.
Адрес без параметров или без буквы m покажет версию приложения для больших экранов:
http://ivanov.narod.ru/MyTrees.html


Меню "Сервис" - "Зашифровать/Расшифровать"

Диалоговое окно "Зашифровать/Расшифровать" применяется для шифрования файлов деревьев .rel публикуемых в Интернете с помощью инструмента Создать файлы Web-приложения. Расшифровка файлов .relx также предусмотрена, хотя практически может быть использована только для проверки правильности паролей.

Элементы интерфейса и порядок работы

Нажмите кнопку Найти..., в диалоговом окне открытия файла выберите нужный тип файлов (Файлы Родственников (*.rel) или Зашифрованные файлы (*.relx)) и выберите нужный файл.

Введите пароль в соответствующее текстовое поле.

В зависимости от того, какой файл (rel или relx) выбран, будет доступна кнопка "Зашифровать" или "Расшифровать". Нажмите доступную кнопку и диалоговом окне сохранения файла введите имя выходного файла - файд будет зашифрован или расшифрован.


Меню "Сервис" - "Справочник по структуре записей"

Это диалоговое окно показывает структуру записей, которыми оперирует программа. По сути своей, это справочник по формату GEDCOM. Причем, если открыть этот диалог в момент, когда в программе не открыт какой-нибудь файл, то будет показана та структура записей, которая заложена в самой программе - то есть "оригинальная", начальная структура. Если открыт какой-нибудь файл, в котором есть свои пользовательские тэги, то эти тэги также будут присутствовать в структуре записей. Отдельно от начальной структуры записей содержание этих пользовательских тэгов можно посмотреть в Редакторе пользовательских тэгов.
Перемещаясь по древовидной структуре записей, можно посмотреть свойства их каждого возможного элемента:

  • Определение - удобочитаемое название элемента.
  • Тэг - имя элемента, используемое в программе, так сказать "для внутреннего пользования".
  • Количество - минимально и максимально возможное количество данного элемента в его родительском элементе.
  • Описание - краткое однострочное описание элемента.
  • Помощь - развернутое описание элемента, какие значения он может принимать, как его редактировать.
  • Тип значения - что представляет собой данный элемент: строка, текст, ссылка на другую запись, выбор из нескольких заранее заданных значений и т.д.
  • Список значений - если тип значения = выбор из нескольких значений.
  • Макс. длина значения - этот параметр, вообще говоря, условный. Он просто отражает ту максимальную длину для данного элемента, которая указана для него в формате GEDCOM. Реально в программе «Родственники» длина строк ограничена только возможностью операционной системы и её компонентов. Теоретический предел - 2147483647 байт, т.е. более 2 Гб.

О том, как организованный данные в программе, смотрите: Структура данных программы.